Opened 8 weeks ago

Closed 5 weeks ago

#10690 closed defect (invalid)

QFG4 error when wraith in room

Reported by: tomasz89 Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: wraith crash sci32 Cc:
Game: Quest for Glory 4

Description

Exiting the dark one cave and walking in to a room with a wraith (I've tried a few) results in the console appearing with:

ERROR:
parameter 0: 0036:f930 (reference, invalid), should be null, integer
[VM] kAbs[5e]: signature mismatch in method wraith::doit (room 566, script 53, localCall ffffffff)!

Attachments (1)

qfg4-cd.010 (47.2 KB) - added by tomasz89 8 weeks ago.
Wraith just to the east.

Download all attachments as: .zip

Change History (11)

Changed 8 weeks ago by tomasz89

Attachment: qfg4-cd.010 added

Wraith just to the east.

comment:1 Changed 8 weeks ago by bluegr

I can't reproduce the crash with this saved game

comment:2 Changed 8 weeks ago by tomasz89

I can reproduce this reliably 100% of the time in any room that contains a wraith.

What further information may I provide to help trace this? Is it a game version mismatch? Is there some other debug back trace information that may aid?

comment:3 Changed 8 weeks ago by bluegr

Keywords: sci32 added

comment:4 Changed 7 weeks ago by bluegr

I tried this again, but I still can't reproduce the bug.

Please tell me the following:

  • Is this an English version of the game?
  • What sort of audio options are you using?
  • Is this a known game variant? I assume you're using the CD version?
  • Have you applied any official game patches?
  • Have you applied any unofficial game patches? (most likely, the NRS patch)

Please note that the CD version did not have any official patches by Sierra - the ones they provided were for the floppy version.

comment:5 Changed 7 weeks ago by tomasz89

  • Yes, it is the English version of the game.
  • For audio, the MT-32 emulator.
  • Yes the CD/voice version from the QFG4 anthology.
  • No, no official patches applied.
  • No, no unofficial patches applied it's straight from the anthology CD. I've not applied New Rising Sun's patches as it is generally unneeded in SCUMMVM.

I will try the GOG version shortly as it's probably going to be the most popular version going forwards..

comment:6 Changed 7 weeks ago by tomasz89

GOG version works fine.

comment:7 Changed 7 weeks ago by bluegr

Priority: blockernormal

comment:8 Changed 5 weeks ago by bluegr

Can you check if the following two files are in the folder of your game, in the version that throws the error:
53.scr
53.hep

If yes, please move them out of the folder and try again

comment:9 Changed 5 weeks ago by tomasz89

Hi,

Spot on. Moving 53.{scr,hep} out of the way, no crash. Moving them back, causes the crash.

comment:10 Changed 5 weeks ago by bluegr

Owner: set to bluegr
Resolution: invalid
Status: newclosed

Right. So, you got broken game files. I can't reproduce this issue - I've also tried with the NRS patch. My suggestion is to just remove these two files altogether. They are meant to be a patch for barrow locations, where wraiths pop up, but you shouldn't really need them with ScummVM.

Thus, I'm closing this as invalid.

Note: See TracTickets for help on using tickets.