Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#10687 closed defect (fixed)

QFG3&QFG4 crash on save

Reported by: tomasz89 Owned by: tomasz89
Priority: blocker Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description

I started a fresh game of QFG3 and attempted to save right away; crash. Same with QFG4 (I was attempting to verify #10138).

Change History (9)

comment:1 by tomasz89, 16 months ago

This is on Linux (Ubuntu) 64 bit, f3cb1fcd84d7ca1dd25b7adb4b54f08c535008ac.

comment:2 by misterhands, 16 months ago

Crash here too on Windows, tested with various SCI games.
Using original save screen works, using ScummVM save screen crashes.

comment:3 by bluegr, 16 months ago

Strange. I just tried saving in both QFG3 and QFG4, and had no problems on Windows with either game.

What graphics/sound settings are you using?

comment:4 by bluegr, 16 months ago

Also, have you set up a save game directory? Are you getting any errors in the console?

comment:5 by tomasz89, 16 months ago

I'll have to check the specific settings when I get home.

The save game directory isn't set explicitly (so it's the default) and I know it works because I can see my previous saves.

No errors in the console, just a straight seg fault.

comment:6 by tomasz89, 16 months ago

Confirmed OK with 54d7336d0886d0a9960baba71168c3471cdb84c6, for both QFG3&4.

comment:7 by tomasz89, 16 months ago

Owner: set to tomasz89
Resolution: fixed
Status: newclosed

comment:8 by bluegr, 16 months ago

So why did you get the crashes?

comment:9 by tomasz89, 16 months ago

I would put the root cause down to some patch between my starting point and f3cb1fcd84d7ca1dd25b7adb4b54f08c535008ac, which was subsequently fixed by the 54d7336d0886d0a9960baba71168c3471cdb84c6 time frame. I didn't change anything in between, just git pulled one day, at which time I saw the crash, then a day later I pulled and rebuilt again, without the crash.

Note: See TracTickets for help on using tickets.