#10669 closed defect (invalid)

Cruise for a Corpse DOS VGA crash (Father Fabiani's Cabin)

Reported by: windale77 Owned by: dreammaster
Priority: normal Component: Engine: Cruise
Keywords: cruise fabiani crash DOS VGA Cc:
Game: Cruise for a Corpse

Description

I just tried Cruise for a Corpse DOS VGA (cruise) and did the following from a walkthrough -

  1. Take the piece of paper next to the ashtray. (press right mousebutton to enter menu)
  2. Unfold the piece of paper and read it [08:10]
  3. Go to the bar (by using the map).
  4. Show the piece of paper to the barman.
  5. He will give you something. [08:20]
  6. Read the Prayer Book.
  7. Take the letter you find inside the book.
  8. Read the letter you found inside the book.
  9. Go to Father Fabiani's cabin and pull the LEFT suitcase.

As soon as I go to Fabiani's cabin it crashes. DOS EGA and Amiga versions don't crash.

Tested on Windows 7 64-bit. ScummVM 2.1.0git3151 (August 1st)

I set this as high priority as it's at the beginning of the game and suprised no-one else noticed !?

Attachments (2)

cruise.s00 (5.7 KB ) - added by windale77 16 months ago.
cruise.2.s00 (12.2 KB ) - added by windale77 16 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 by windale77, 16 months ago

Also tried Stable version of SCUMMVM v2.0.0 Windows 32-bit, same crash.

comment:2 by dreammaster, 16 months ago

Despite the short sequence of events you list, it would still be helpful to attach a savegame from the cabin just before the crash, particularly if it's still replicable after loading it.

by windale77, 16 months ago

Attachment: cruise.s00 added

comment:3 by windale77, 16 months ago

When loading the save-game I get

'Assertion failed!'
File: engines/cruise/saveload.cpp, Line 920

Expression: 0

(You have to pass the protection I think before you can load the game).

by windale77, 16 months ago

Attachment: cruise.2.s00 added

comment:4 by windale77, 16 months ago

From the second attached save, get in game, press both mouse buttons and choose load game. After load, right click and choose map and select Father Fabiani's cabin (top right) then click the icon at the bottom right of screen.

comment:5 by dreammaster, 16 months ago

Thanks. I tested it with my own copy and wasn't able to replicate any crash. It may be that your copy has become corrupted. I'd suggest you try making a fresh copy from your original discs and see if it makes any difference.

comment:6 by dreammaster, 16 months ago

Owner: set to dreammaster
Priority: highnormal
Resolution: worksforme
Status: newpending

comment:7 by windale77, 16 months ago

Thanks for confirming. It seems the file 'D4' was corrupted. It doesn't crash now. This can be closed.

Last edited 16 months ago by windale77 (previous) (diff)

comment:8 by dreammaster, 16 months ago

Resolution: worksformeinvalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.