Opened 4 months ago

Closed 4 months ago

#10649 closed defect (invalid)

XEEN: Assertion failed - World of Xeen

Reported by: enderandrew Owned by: dreammaster
Priority: normal Component: Engine: Xeen
Keywords: Cc:
Game: Might and Magic: World of Xeen

Description

Assertion failed crash when launching World of Xeen. I've tried my 1-6 CD compilation and the GOG talkie version.

I'm using the current 64-bit daily snapshot (scummvm -v returns no version number) from August 3rd, 2018 on Windows 10.

https://imgur.com/a/YjlRMv3

Change History (5)

comment:1 Changed 4 months ago by enderandrew

Log file says version:

ScummVM 2.1.0git2144-gf3bccbd

comment:2 Changed 4 months ago by dreammaster

Game: Might and Magic: World of Xeen
Summary: Assertion failed - World of XeenXEEN: Assertion failed - World of Xeen

I'm not familiar with 64-bit builds. Unless you actually mean the 32-bit build downloadable from the scummvm.org website under the downloads section. If not, then wherever you got the build from may be using an outdated xeen.ccs. Try the 32-bit version and see if it makes any difference. For these builds, the date of compilation should appear at the top of the launcher, right under the ScummVM title. Make sure it does indeed give today's date.

I'm not sure if the daily builds embed the data files within them like official builds do, but even if so, copying xeen.ccs to the game folder should override the one embedded in the executable. So you could try copying the latest one to that folder. Or deleting any existing copy that's there. Speaking of which, you might also want to check whether in the game's dialog (Edit Game) or the Options dialog Paths tab you have an Extras path set up. It's possible you have one or the other pointing to an older copy of the xeen.ccs

Let me know if that doesn't fix it, and I'll bump up the version number of the datafile.. it's about due now that development has finished. That at least wpi;d mean you'd get a proper version error dialog rather than an assert if the problem is that it's locating an older copy of it.

comment:3 Changed 4 months ago by enderandrew

The build is official from here:

http://buildbot.scummvm.org/snapshots/master/mingw-w64-master-latest.zip

As for the date, it looks like while there are new commits in Github, the latest build shows May 12th. I'm not sure why buildbot isn't making new builds.

xeen.ccs isn't in the build itself.

I pulled it from here according to the instructions:

https://github.com/scummvm/scummvm/blob/master/dists/engine-data/xeen.ccs?raw=true

So it is the latest from master. But I'll try 32-bit as well here in a bit.

Last edited 4 months ago by enderandrew (previous) (diff)

comment:4 Changed 4 months ago by enderandrew

That seems to be the issue.

xeen.ccs has changed, but buildbot isn't making new builds. If I grab a copy of xeen.ccs from before May 12th, the game launches.

https://github.com/scummvm/scummvm/blob/461171ced17993aec5ec6ff6dacaf5057870eb62/dists/engine-data/xeen.ccs

So this isn't a xeen engine bug. The problem is that buildbot isn't making new builds.

comment:5 Changed 4 months ago by dreammaster

Owner: set to dreammaster
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.