Opened 8 months ago

Closed 4 months ago

Last modified 4 months ago

#10645 closed enhancement (fixed)

GUI: Match tab body style across all Options tabs (Global & Game).

Reported by: macca8 Owned by: bgK
Priority: low Component: GUI
Keywords: Cc:
Game:

Description

The recent addition of the Cloud tab and updated Graphics tabs (Global & Game) has introduced style enhancements not yet available for other tabs.

These include:

  • a higher top edge with rounded top corners.
  • a better proportioned tab header (the tab name) as a result of the raised edge.
  • a broader shadow along the bottom edge.

The unwanted side effect of these changes is the apparent shifting of the tab body (though the contents are unaffected) when switching from a new style tab to an old style tab.

In my opinion, I’d recommend going with the new style, since it not only matches the tab’s top & bottom edges, it’s also consistent with the styling of the parent container that holds all the tabs.

The only blemish with the new style is a line now separates the header from the body when the tab is selected.

It’s also clear that the Cloud & Graphics tab styles have been imported from the same source (criezy’s personal build?) since they’re a perfect match, so perhaps the other tabs are already available, but just not implemented.

This request applies to all tabs associated with either Global Options or Game Options.

Thanks for your consideration.

Current Daily Build: 2.1.0git3151-gde886a8b58(1 August 2018)
Platform: Intel Mac (OS X 10.6.8, 10.11.6)

Attachments (2)

New style tab.png (38.3 KB) - added by macca8 8 months ago.
New styling
Old style tab.png (38.8 KB) - added by macca8 8 months ago.
Old styling (all tabs other than Graphics & Cloud).

Download all attachments as: .zip

Change History (4)

Changed 8 months ago by macca8

Attachment: New style tab.png added

New styling

Changed 8 months ago by macca8

Attachment: Old style tab.png added

Old styling (all tabs other than Graphics & Cloud).

comment:1 Changed 4 months ago by bgK

Owner: set to bgK
Resolution: fixed
Status: newclosed

The background of the tab / scroll-container was being drawn twice. I changed it to being drawn once only in commit 7c570d9b253206e9, restoring the non-scrolling appearance.

comment:2 Changed 4 months ago by macca8

Thanks bgK.
Always intrigued by your ability to unravel seemingly obscure root causes for issues.

Note: See TracTickets for help on using tickets.