Opened 4 years ago

Closed 6 weeks ago

#10630 closed defect (fixed)

SCUMM/HE: BB2003 - won't play some sounds

Reported by: kikikza Owned by: sudobash1
Priority: normal Component: Engine: SCUMM
Version: Keywords: Sound, Audio, Backyard, Baseball
Cc: Game: Backyard Baseball

Description

I've been playing BB2003 for a while now, and I've been having this issue where many sounds (usually the players talking or the announcers) don't play, and some white text flashes in the upper right-hand corner which appears to be something like a file path. The game functions normally otherwise however. I've uninstalled/reinstalled the .iso for BB2003 and ScummVM, but neither changed anything

Attachments (2)

scummvm.log (1.7 KB ) - added by theoldsport 3 years ago.
scummvm.2.log (8.6 KB ) - added by Bpendragon 2 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 by kikikza, 4 years ago

I forgot to mention - this is on a Mac running 10.13, but the issue has been persistent since 2015 or so

comment:2 by digitall, 4 years ago

Component: --Unset--Engine: SCUMM

by theoldsport, 3 years ago

Attachment: scummvm.log added

comment:3 by theoldsport, 3 years ago

Can confirm this still occurs on ScummVM 2.1.0. I've replicated on Windows 10 and Android. I've also uploaded a log that shows warnings which occurs at the same time as the noted text flashing (where audio should play).

by Bpendragon, 2 years ago

Attachment: scummvm.2.log added

comment:4 by Bpendragon, 2 years ago

Just confirmed on ScummVM 2.1.2 running on Windows 10 Pro 1909

Log Attached, most errors are SubOP 85, some are SubOP 5

comment:5 by raziel-, 2 years ago

Summary: SCUMMVM won't play some sounds in Backyard Baseball 2003SCUMM: BB2003 - won't play some sounds

comment:6 by kikikza, 2 years ago

It's unfortunately still occurring on multiple computers and androids for me.

comment:7 by sev-, 3 months ago

Summary: SCUMM: BB2003 - won't play some soundsSCUMM/HE: BB2003 - won't play some sounds

comment:8 by sudobash1, 2 months ago

I have made a PR to resolve this issue #3840. It was an issue with determining the duration of the voice samples due to the somewhat uncommon wav format used.

comment:9 by bluegr, 6 weeks ago

Owner: set to sudobash1
Resolution: fixed
Status: newclosed

Thanks for your work on this sudobash1! The PR has been merged, so this can be closed now

Note: See TracTickets for help on using tickets.