Opened 2 years ago

Closed 2 months ago

#10622 closed enhancement (duplicate)

PEGASUS: Pegasus Prime error/unknown version

Reported by: thesentrygamer Owned by:
Priority: normal Component: Engine: Pegasus
Keywords: unknown-game Cc:
Game: Journeyman Project Pegasus Prime

Description

Version: GOG-win
OS: Windows 7 service pack 1
"Matched game IDs for the The Journeyman Project: Pegasus Prime engine: pegasus-mac

{"JMP PP Resources", 0, "d13a602d2498010d720a6534f097f88b", 2075337}, "
Please help

Attachments (1)

Capture.PNG (60.0 KB ) - added by thesentrygamer 2 years ago.
snip of error when i selected "PP Data" and clicked Add Game

Download all attachments as: .zip

Change History (7)

by thesentrygamer, 2 years ago

Attachment: Capture.PNG added

snip of error when i selected "PP Data" and clicked Add Game

comment:1 by dafioram, 2 years ago

Thanks for your report.

What ScummVM version are you using?

comment:2 by eriktorbjorn, 2 years ago

As far as I understand, this version isn't supported by ScummVM, unfortunately. It's one of those games that have a bewildering number of different versions:

  • The Journeyman Project. The original version, released in 1992.
  • Journeyman Project Turbo! The 1994 re-release with "decreased loading times and improved animation quality".
  • Pegasus Prime. The 1997 "Director's Cut" Macintosh remake. ScummVM supports this version.
  • Pegasus Prime. The 2014 previously unreleased DVD version of the "Director's Cut", with additional features "from the impossible-to-find Playstation version".

Sources:

https://en.wikipedia.org/wiki/The_Journeyman_Project
http://thejourneymanproject.com/presto/journeymanprime/faq.html

The 2014 version does use ScummVM, and you used to be able to download their source code from http://thejourneymanproject.com/presto/journeymanprime/support.html though at the time of writing none of the links there work for me. (I was able to download it earlier this year, so hopefully it's only temporarily down.) There was also source code included on the physical DVD version.

From what I understand, their version only supports the 2014 version, not the 1997 version. I'm not aware of any active project to merge the two, though admittedly there are lots of things I'm not aware of.

comment:3 by dafioram, 2 years ago

This ticket is about the DVD version. It is a duplicate of #10347.

ScummVM currently supports the CD/1997 version, but the DVD/2014 version is on a branch.

comment:4 by digitall, 12 months ago

Game: Journeyman Project Pegasus Prime
Keywords: JMP PP removed

comment:5 by Thunderforge, 12 months ago

Keywords: unknown-game added

comment:6 by raziel-, 2 months ago

Priority: highnormal
Resolution: duplicate
Status: newclosed
Summary: Journeyman Project - Pegasus Prime errorPEGASUS: Pegasus Prime error/unknown version
Type: defectenhancement

Closing as duplicate of #10347, as confirmed in comment:3

Please add any more information to the above item.

Thanks

Note: See TracTickets for help on using tickets.