Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#10606 closed defect (fixed)

Myst: Mechanical Age: Achenar's torture chamber doesn't flash visually when hitting the switch

Reported by: theAntaegonist Owned by: bgK
Priority: low Component: Engine: Mohawk
Keywords: Myst, Mechanical Cc:
Game: Myst

Description

The torture chamber in Achenar's hidden room on the Mechanical Age fortress doesn't flash visually when hitting the electric switch. Only the "zap" audio plays, but there isn't a corresponding visual feedback.

Scummvm: listed as 2.1.0git
Machine: Windows 10 64bit
Game: Myst ME from GOG (listed as 1.0 SVM UPDATE in GOG Galaxy)
Scummvm setting: defaults from GOG install

Attachments (1)

Capture.PNG (575.7 KB ) - added by theAntaegonist 2 years ago.
screenshot of Achenar's torture chamber with switch for reference

Download all attachments as: .zip

Change History (3)

by theAntaegonist, 2 years ago

Attachment: Capture.PNG added

screenshot of Achenar's torture chamber with switch for reference

comment:1 by dafioram, 2 years ago

Thanks for your report.
ScummVM has the same behavior for Myst ME and Myst in that it plays the zap sound occasionally, and no white flash every time the switch is flipped
In Myst ME original engine it has the zapping sound and occasionally a flash. In Myst it has the white flash every time you flip the switch, but no zapping sound.

Last edited 2 years ago by bgK (previous) (diff)

comment:2 by bgK, 2 years ago

Owner: set to bgK
Resolution: fixed
Status: newclosed

Thanks for your report, this was fixed in commit 5cff361. Daily builds with version 2.1.0git-2787 and above should behave correctly.

Last edited 2 years ago by bgK (previous) (diff)
Note: See TracTickets for help on using tickets.