Opened 2 years ago

Closed 8 months ago

#10597 closed defect (wontfix)

Myst: Black/frozen graphic at the start of Myst flyby animation

Reported by: mgiuca Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Myst

Description

Version: 2.1.0git
Game: Myst Masterpiece Edition (GOG version, June 2018)
OS: Windows 10

Steps to reproduce:

  1. Start a new game.
  2. Watch the introduction where the book falls onto the ground.
  3. Click the book.
  4. Watch the small video of flying to the island and landing on the dock.

Note that when the book first opens, the panel is black for a few seconds. Then it is frozen for a few seconds on the water. After that, the video resumes as normal.

This is not a ScummVM issue; it is a problem with the data file QTW\INTRO\INTRO2.MOV. However, this news page tells us to report bugs here for issues with the Myst 25th Anniversary launch.

This has always been an issue with Myst Masterpiece edition since its 2000 release. However, it was not an issue with the original Myst game (at least in the 1996 Windows release). So it should be possible to fix this data file by splicing in the first few seconds of video from the original, un-remastered, Myst game. This isn't really something the ScummVM team can do, it's more of a question of updating the data files for the 25th Anniversary release.

Change History (4)

comment:1 by thegreatprophetzarquon, 2 years ago

An ideal source for the file would be the MAC version of MYST masterpice, which has high quality audio to match the rest of the game. (Ideally all videos could be replaced by the MAC's versions, because it has the highest quality audio of all releases.) However, support would have to be added for it's audio codec and the different type of MOV container. A simple fix would be to replace the "INTRO2.MOV" file with the equivalent version from the original windows version of MYST. (I tested this on a Scummvm setup and it drops in perfectly with no adjustment.)

Last edited 2 years ago by thegreatprophetzarquon (previous) (diff)

in reply to:  1 comment:2 by thegreatprophetzarquon, 2 years ago

I realize these bugs are outside the scope of the Scummvm project, but they are important to ensuring the the 25th Anniversary Edition doesn't have any glaring issues that could be corrected, so thanks for bearing with us.

Last edited 2 years ago by thegreatprophetzarquon (previous) (diff)

comment:3 by thegreatprophetzarquon, 2 years ago

The Cyan logo was fixed by dropping in the Mac version of the logo (ticket:10601). I realized this means that you can drop in the Mac versions of the videos without too many problems. Sure enough, I can take the INTRO2.MOV file from the Myst Masterpiece Mac CD and it works just fine in ScummVM.
This would be a simple fix for a longstanding nasty error.

comment:4 by bgK, 8 months ago

Owner: set to bgK
Resolution: wontfix
Status: newclosed

Unfortunately the INTRO2.MOV from the Myst Masterpiece Mac version is not exactly the same (size / position) and results in another minor graphical glitch. This is why it was not used in the Myst 25th anniversary versions.

Note: See TracTickets for help on using tickets.