Opened 8 months ago

Closed 6 months ago

#10594 closed defect (fixed)

Myst: Mouse cursor has ugly border in fullscreen mode

Reported by: mgiuca Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: myst25gog Cc:
Game: Myst

Description

Version: 2.1.0git
Game: Myst Masterpiece Edition (GOG version, June 2018)
OS: Windows 10

The mouse cursor has an ugly white border around it when the game is scaled up from its native resolution. See attached screenshot.

Not an issue when in windowed mode at the native resolution (but also reproducible if the window is resized). Not an issue in Riven.

Attachments (1)

myst-hand.png (12.2 KB) - added by mgiuca 8 months ago.
Mouse cursor

Download all attachments as: .zip

Change History (6)

Changed 8 months ago by mgiuca

Attachment: myst-hand.png added

Mouse cursor

comment:1 Changed 8 months ago by dafioram

Thanks for your report.

I am having trouble seeing the white border in your picture. The scaling used for fullscreen may make edges look a little fuzzy, is that what you are seeing? In game the cursor looks very sharp to me. Is there a particular part of the game or age where it looks different?

comment:2 Changed 8 months ago by lotharsm

This is related to the bilinear filtering GOG.com enabled in their Myst release, I hope this will be disabled by default with the next update.

As a workaround, disable bilinear filtering by pressing CTRL+ALT+F.

comment:3 Changed 8 months ago by lotharsm

Keywords: myst25gog added
Owner: set to lotharsm

comment:4 Changed 8 months ago by mgiuca

@dafioram: No, it happens everywhere in the game, though on a dark background it's more noticeable. It was hard to capture a screenshot in fullscreen because the cursor would end up in a different spot in the screenshot than where it really was.

I suspect what's happening is that the cursor image is surrounded by white, invisible pixels. When the game is scaled, the cursor image itself is scaled up using bilinear filtering and the edge pixels are blended with the invisible white pixels which aren't meant to be seen.

Disabling bilinear filtering for the whole game won't look great unless the game is scaled to an exact multiple. (Which would actually look fine; at 1920x1080 you can scale up the game by exactly 3X and it has a narrow black border, as I mocked up here and discussed here.)

comment:5 Changed 6 months ago by bgK

Owner: changed from lotharsm to bgK
Resolution: fixed
Status: newclosed

Thanks for your report. The issue with cursor color fringing in ScummVM's OpenGL renderer was resolved in commit 3376597.

Note: See TracTickets for help on using tickets.