Opened 2 years ago

Closed 2 years ago

#10582 closed defect (fixed)

SCI: KQ6: AmigaOS4: Cursors broken

Reported by: raziel- Owned by: raziel-
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

ScummVM 2.1.0git (Jun 24 2018 20:36:35)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG cloud (servers, local)

In the game, all (except two) cursors are broken in some way.
It seems as if the position, the cursor graphics is read from, is slightly shifted and wrongly scaled, at least, thats how it looks like in the screenshots.

The "eye" cursor seems to be doubled in size and cut in the middle.
The "pointer" cursors seems to be the right size, but part of the "talk bubble" cursor is also drawn.
The "walk" cursor also seems to have half of the "talk bubble" cursor drawn.

On a scene change the cursors are even worse, doubled (maybe even tripled) in size and cut off.

Both the original and "silver" cursors are affected.

Screenshots attached

King's Quest VI: Heir Today, Gone Tomorrow (CD/Windows/English)

AmigaOS4 - PPC - SDL - BE
gcc (adtools build 5.4.0) 5.4.0

Attachments (3)

King's Quest VI_ Cursor_Eye.png (61.4 KB ) - added by raziel- 2 years ago.
Eye Cursor
King's Quest VI_ Cursor_Pointer.png (83.9 KB ) - added by raziel- 2 years ago.
Pointer Cursor
King's Quest VI_ Cursor_Walk.png (61.6 KB ) - added by raziel- 2 years ago.
Walk Cursor

Download all attachments as: .zip

Change History (6)

by raziel-, 2 years ago

Eye Cursor

by raziel-, 2 years ago

Pointer Cursor

by raziel-, 2 years ago

Walk Cursor

comment:1 by dafioram, 2 years ago

Game: King's Quest 4King's Quest 6
Summary: SCI: KQ6 - Cursors brokenSCI: KQ6: AmigaOS4: Cursors broken

comment:2 by raziel-, 2 years ago

Not sure if it was a regression, a broken local build or dirty glasses...it's gone with the latest sources.

comment:3 by raziel-, 2 years ago

Owner: set to raziel-
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.