Opened 18 months ago

Closed 18 months ago

Last modified 16 months ago

#10565 closed defect (worksforme)

ZVISION: ZGI: Soft-lock when igniting figurine

Reported by: Nicholas-Steel Owned by: dafioram
Priority: normal Component: Engine: ZVision
Keywords: Cc:
Game: Zork Grand Inquisitor

Description

When I light the Grand Inquisitor figurine on fire with the cigar, it catches on fire but I can't leave the screen to then hide in the barrel and progress the game. Clicking the bottom of the screen, with the mouse courser pointing downwards, does nothing. Saving and loading my progress while in the bugged state doesn't fix it either (I can provide this bugged save if you desire it).

1) Head to town and turn up the volume of the loud speaker.
2) While the propaganda plays, steal the plastic 6-pack rings from the fishery to the left of the loud speaker.
3) Go to the docks, apply the plastic rings to the hook and then activate the device to fish out a Lamp.
4) Hand the Lamp to the first building on the right side of town (when entering the town from the entrance to the town).
5) Click the same building after the cutscenes to be given a Cigar.
6) Go all the way in to Town to reach a barrel with some figurines on it, click on the barrel and then use a Cigar to ignite the unpackaged figurine.
7) Try to leave the screen by clicking the bottom edge of the screen.

ScummVM v2.0
GOG DVD Version of the game
Windows 10 Pro x64 v1803

Attachments (2)

zgi-win-1.000 (14.8 KB ) - added by dafioram 18 months ago.
DVD version right before lighting figurines
zgi-dvd.000 (15.8 KB ) - added by Nicholas-Steel 18 months ago.
Save created while the bugged state is in effect.

Download all attachments as: .zip

Change History (13)

comment:1 by bonki, 18 months ago

Component: --Unset--Engine: ZVision
Keywords: Soft-lock Softlock Bug Crash removed
Summary: Soft-lock when igniting figurine early on in Zork: Grand InquisitorZVISION: ZGI: Soft-lock when igniting figurine

Thanks for your report! Please do upload the savegame.

comment:2 by dafioram, 18 months ago

Seems to work fine on the CD version.

comment:3 by dafioram, 18 months ago

Priority: highblocker

But not the DVD version.

by dafioram, 18 months ago

Attachment: zgi-win-1.000 added

DVD version right before lighting figurines

comment:4 by dafioram, 18 months ago

Owner: set to Nicholas-Steel
Resolution: invalid
Status: newpending

Nicholas-Steel, it is now working for me.

Can you try it again and see if it works?

in reply to:  4 comment:5 by Nicholas-Steel, 18 months ago

Replying to dafioram:

Nicholas-Steel, it is now working for me.

Can you try it again and see if it works?

Sure, but... are you suggesting I download a build newer than v2.0? If yes, please link me to a pre-compiled build compatible with my O/S.

by Nicholas-Steel, 18 months ago

Attachment: zgi-dvd.000 added

Save created while the bugged state is in effect.

comment:6 by dafioram, 18 months ago

Priority: blockernormal
Resolution: invalid
Status: pendingnew

Nicholas-Steel I cannot reproduce it. Doesn't matter if I use a recent version of scummvm or the 2.0.0 packaged with GoG DVD release. Even the saved game I attached works fine. I was able to reproduce it earlier under what conditions I don't know, but your save state is obviously blocked.

You are welcome to try the latest scummvm which can be obtained at https://www.scummvm.org/downloads/scummvm-win32.exe. You will need to set your extras folder for scummvm to point to the extra folder in ZGI that has the fonts.

If you are able to determine what steps lead to the soft-lock versus not that would help immensely.

If you want a saved game right after the figurine I can provide that.

comment:7 by dafioram, 18 months ago

Owner: Nicholas-Steel removed

comment:8 by Nicholas-Steel, 18 months ago

Hmm, I can't reproduce it after re-installing the game.

I noticed that when GOG upgraded everyone to the DVD version with ScummVM v2.0 (from ZEngine) that there's still a lot of old data left over in the installation folder related to ZEngine and god knows what else. Uninstalling the game didn't remove everything from the installation folder either (ZEngine stuff etc. remained)

So I manually deleted the installation folder after uninstalling the game and then I installed the game again. This time there is no redundant ZEngine files cluttering up the installation folder. Now the game can progress without soft-locking.

comment:9 by dafioram, 18 months ago

Owner: set to dafioram
Resolution: worksforme
Status: newclosed

Please reopen this bug if the issue pops up again. While we were able to produce this bug initially we cannot now and we need it to be reproducible to fix it.

comment:10 by Nicholas-Steel, 18 months ago

I just finished the game and this intermittent issue was the only problem I encountered in the game.

comment:11 by eriktorbjorn, 16 months ago

I didn't see this bug when I filed bug #10605 ("ZVISION: ZGI: Stuck on the burning doll screen"), but hopefully both have been fixed now. See https://github.com/scummvm/scummvm/pull/1236 for further details.

Note: See TracTickets for help on using tickets.