#10564 closed defect (wontfix)

MOHAWK: RIVEN: CD: Cage lowering video in Gehn's lair has playback issues

Reported by: MDogherra Owned by: bgK
Priority: low Component: Engine: Mohawk
Keywords: Cc:
Game: Riven

Description

-Cyan Employee Bug-

Where: Gehn's Lair, the video for lowering the cage

What: The start of this movie repeats once shortly after beginning

Checked against daily build mingw-w32-master-5534b4b6

Attachments (1)

30 - Gehn's room.rvn (8.7 KB ) - added by dafioram 17 months ago.
CD save from original

Download all attachments as: .zip

Change History (7)

comment:1 by sev-, 17 months ago

Attached savegame wold be helpful.

comment:2 by dafioram, 17 months ago

Priority: normallow
Summary: Cage lowering video in Gehn's lair has playback issuesMOHAWK: RIVEN: CD: Cage lowering video in Gehn's lair has playback issues

I am guessing MDogherra is using the assets from GoG which original had the cd version.

ScummVM DVD Version: Bug not present
ScummVM CD Version: Bug present
Original DVD: Bug not present
Original CD: Bug present

by dafioram, 17 months ago

Attachment: 30 - Gehn's room.rvn added

CD save from original

comment:3 by bgK, 17 months ago

As dafioram noticed, the problem is with the video that is included in the CD version of the game. There is not much we can do.

I've just downloaded Riven from GOG to check. They are providing the DVD version that does not have this issue. MDogherra, is there any reason you are using the CD version of the game instead of the newer and generally better DVD version?

comment:4 by MDogherra, 17 months ago

Hey all,

Afraid we've been using the releases packed with an earlier scummVM given to us by GoG, then pointing the dev scummVM buids at those GoG installs. I'll have our guys do some comparison stuffs between what was given to us in the package, vs what GoG currently sells on their store and get back to you here.

comment:5 by MDogherra, 17 months ago

Sorry it took me a bit to get back here. The version GoG has up, as far as any of us can tell, is the CD version. We ripped the newest disc we have on hand here, the 10th anniversary DVD release, and everything is working perfectly. So once we make sure GoG is handing out the right assets, this should be all set.

comment:6 by bgK, 16 months ago

Owner: set to bgK
Resolution: wontfix
Status: newclosed

Closing this as there is nothing we can do about it. In the end the new re-release uses the DVD version assets that don't have this issue.

Note: See TracTickets for help on using tickets.