#10538 closed defect (invalid)

SCI: Lighthouse: Crash when loading a save from the cmd line

Reported by: dafioram Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Lighthouse

Description

Trying to load a valid saved game from the command line crashes.

It reports:
Common::Array: failure to allocate 2405433348 bytes!

If I type bt into the debug window it reports:
SegManager::getScript(): seg id b is not in memory!

This is lighthouse v2a.

Change History (1)

comment:1 by bluegr, 14 months ago

Owner: set to bluegr
Resolution: invalid
Status: newclosed

I can't reproduce this. I've tried both Lighthouse v1.0 and v2.0a

The error you're getting indicates that you've got a corrupted saved game.

Closing as invalid

Note: See TracTickets for help on using tickets.