#10528 closed defect (duplicate)

SPY FOX 3 GERMAN: Crash in the Hair Dressing Room.

Reported by: Saleck Owned by: svenmeier
Priority: high Component: Engine: SCUMM
Keywords: Spy Fox Crash German Cc: svenmeier
Game: Spy Fox 3

Description

Hello,

There is a bug with the German version of SPY Fox 3. When entering the Hair Dressing Machine room, the game will crash with the following:

(21:2067:0x11210): Script 2067, offset 0x11210: [73] o6_jump()
(21:2067:0x11206): Script 2067, offset 0x11206: [3] o6_pushWordVar()
(21:2067:0x11209): Script 2067, offset 0x11209: [0] o6_pushByte()
(21:2067:0x1120B): Script 2067, offset 0x1120b: [D2] o6_getAnimateVariable()
(21:2067:0x1120C): Script 2067, offset 0x1120c: [5C] o6_if()
(21:2067:0x1120F): Script 2067, offset 0x1120f: [6C] o6_breakHere()
(21:2067:0x11210): Script 2067, offset 0x11210: [73] o6_jump()
(21:2067:0x11206): Script 2067, offset 0x11206: [3] o6_pushWordVar()
(21:2067:0x11209): Script 2067, offset 0x11209: [0] o6_pushByte()
(21:2067:0x1120B): Script 2067, offset 0x1120b: [D2] o6_getAnimateVariable()
(21:2067:0x1120C): Script 2067, offset 0x1120c: [5C] o6_if()
(21:2067:0x1120F): Script 2067, offset 0x1120f: [6C] o6_breakHere()
(21:2067:0x11210): Script 2067, offset 0x11210: [73] o6_jump()
(21:2067:0x11206): Script 2067, offset 0x11206: [3] o6_pushWordVar()
(21:2067:0x11209): Script 2067, offset 0x11209: [0] o6_pushByte()
(21:2067:0x1120B): Script 2067, offset 0x1120b: [D2] o6_getAnimateVariable()
(21:2067:0x1120C): Script 2067, offset 0x1120c: [5C] o6_if()
(21:2067:0x1120F): Script 2067, offset 0x1120f: [6C] o6_breakHere()
Ending with undefined uSweat token FF47!

This has been verified with the Steam version.

Here's some info I could find on the problem:

---

ERROR: Ending with undefined uSweat token FF47!
(Comes from akos.cpp line #1758)

Regarding the theory that this is a missing AKOS opcde, that seems unlikely to me: AKOS codes are of the form 0xC0?? and 0xFF47 just does not fit in there.

I've taken a look at the source code this afternoon and indeed the 0XFF47 doesn't fit.

Change History (1)

comment:1 Changed 14 months ago by svenmeier

Cc: svenmeier added
Owner: set to svenmeier
Resolution: duplicate
Status: newclosed

This is a duplicate of #3813

Note: See TracTickets for help on using tickets.