Opened 16 years ago

Closed 12 years ago

#1052 closed defect (fixed)

INDY3: problems in Berlin with Hitler

Reported by: SF/quietust Owned by: fingolfin
Priority: high Component: Engine: SCUMM
Keywords: script Cc:
Game: Indiana Jones 3

Description

ScummVM 0.5.0pre-cvs (Jul 21 2003 02:04:07)

In the Amiga version of INDY3EGA, when Indy meets
Hitler in Berlin there are 2 problems*:

1. Hitler does not face Indy (i.e. to the right) when
the "Offer an item"/"Throw a punch" prompt is displayed.

2. When you give Hitler an item, it isn't showing him
accepting the item, autographing it, or giving it back to
Indy - he just stands there for a few seconds and then
walks away.

* If you hit ESC before running into Hitler to skip directly
to the prompt (either at the burning books, or
immediately before Hitler walks up), everything will work
as expected.

Ticket imported from: #774783. Ticket imported from: bugs/1052.

Attachments (3)

indy3ega.s01 (53.8 KB) - added by SF/quietust 16 years ago.
Indy3EGA - 1 second before Berlin
indy3.s01 (55.9 KB) - added by SF/quietust 16 years ago.
Indy3VGA - 1 second before Berlin
indy3_berlin.patch (534 bytes) - added by bluegr 12 years ago.
Indy 3 fix for Hitler in Berlin

Download all attachments as: .zip

Change History (18)

comment:1 Changed 16 years ago by fingolfin

Same problem a swith that other berlin bug report, w/o a save
game, nothing to be done <shrug>. At least as long as nobody is
willing to play thru to that point with the PC Indy3EGA version and
provide a savegame ('cause I don't have the nerves to play thru
Indy3 just to maybe be able to fix a bug).

comment:2 Changed 16 years ago by SF/quietust

One thing which may be semi-interesting to note is that the
Indy3 VGA has the exact same problem. I'll get a pair of
savegames: one for each, just before Berlin - it should help
solve that odd script crash as well.
I'll upload the savegames as soon as I get far enough into the
game (which shouldn't take long if I use Ctrl+F liberally).

Changed 16 years ago by SF/quietust

Attachment: indy3ega.s01 added

Indy3EGA - 1 second before Berlin

Changed 16 years ago by SF/quietust

Attachment: indy3.s01 added

Indy3VGA - 1 second before Berlin

comment:3 Changed 16 years ago by fingolfin

This actually sometimes works, and sometimes not - this is
caused by the same issue as reported in bug #770690. At least for
the EGA version, it works now.

I can't reproduce it for the VGA version at all - Hitler does face
me, and does sign the book). I am not skipping to it either.

Leaving this open for now, till we resolve the VGA version issue...

BTW while I can load your savegame for the VGA version, it
doesn't quite work for me. Instead of Indy walking to Henry, he
walks straight upwards into the sky... I hope this is just because
we have different versions or so, and not yet another regression
... <sigh>

comment:4 Changed 16 years ago by fingolfin

Owner: set to fingolfin

comment:5 Changed 16 years ago by fingolfin

OK this should be fixed now, too - just had to extend the EGA
version hack to the VGA version, too.

Now I wonder if this actually works correctly with the original
engine in the VGA version... the data file is wrong there, too, but
in a different way.

comment:6 Changed 16 years ago by fingolfin

Resolution: fixed
Status: newclosed
Summary: INDY3EGA - problems in Berlin with HitlerINDY3: problems in Berlin with Hitler

comment:7 Changed 16 years ago by SF/quietust

Regarding the "walking into the sky" thing with the VGA
savegame: the first time I tried re-loading it (with the same
version I created it with), the exact same thing happened -
after I loaded it again, it worked fine (and gave the same
buggy Hitler behaviour).

comment:8 Changed 12 years ago by fingolfin

Status: closednew

comment:9 Changed 12 years ago by fingolfin

I am temporarily reopening this, as after my recent walk code fixes, issue #1 occurs again: Hitler is not facing Indy. That is, he walks to Indy, and then makes a funny "spin around" before finally facing the player. Something is wrong with our turning code, obviously.

comment:10 Changed 12 years ago by fingolfin

Oh, and of coure #2 occurs, too, it's a direct consequence of #1. I could work around this by forcing a certain actor direction, but I'll rather try to fix the actual issue behind this.

comment:11 Changed 12 years ago by fingolfin

Priority: normalhigh

comment:12 Changed 12 years ago by fingolfin

This one proved to be tougher than I thought. Would be really nice to get it properly fixed before 0.10.0 :-/

Changed 12 years ago by bluegr

Attachment: indy3_berlin.patch added

Indy 3 fix for Hitler in Berlin

comment:13 Changed 12 years ago by bluegr

Attaching a possible fix for Hitler's spinning

Note that for some reason, Hitler is in front of Indy, but he's drawn behind Elsa and the guard as he leaves. The guard however, is drawn in front of Elsa. Don't remember how original behaved in that spot and if this sprite drawing is a bug or not
File Added: indy3_berlin.patch

comment:14 Changed 12 years ago by bluegr

Status: newclosed

comment:15 Changed 12 years ago by bluegr

I submitted my fix after talking with fingolfin. This issue should be fixed now in the latest SVN
Closing

Note: See TracTickets for help on using tickets.