Opened 2 years ago

Closed 3 months ago

Last modified 3 months ago

#10509 closed defect (fixed)

SCI: Font errors in Polish games

Reported by: MrPepka Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 1

Description

So i'm detect that ScummVM 2.0.0 has a broken support for game series Leisure Suit Larry
Leisure Suit Larry 1 EGA - worked
Leisure Suit Larry 1 VGA - If you answer the question about the game distributor incorrectly the game is crash. In addition, everything works without a problems
Leisure Suit Larry 2 - crash when launched
Leisure Suit Larry 3 - the crash occurs when you try to skip the cutscene or if you wait it out, the crash happens when the island shows up
Leisure Suit Larry 5 - the crash happens when you skip the cutscene or if you wait it out, the crash happens during the first dialogue
Leisure Suit Larry 6 - the crash occurs when initiating a conversation with the receptionist
Language Games: Polish
Version Games: DOS
Windows 8.1 Enterprise 64-bit
Last version ScummVM without the bug: 1.9.0

Attachments (4)

ScummVM 1.png (1.5 MB ) - added by MrPepka 2 years ago.
ScummVM 7.png (1.5 MB ) - added by MrPepka 2 years ago.
ScummVM 8.png (1.8 MB ) - added by MrPepka 2 years ago.
ScummVM 9.png (1.8 MB ) - added by MrPepka 2 years ago.

Change History (11)

by MrPepka, 2 years ago

Attachment: ScummVM 1.png added

comment:1 by MrPepka, 2 years ago

LSL 1 VGA also crashes when saving.

by MrPepka, 2 years ago

Attachment: ScummVM 7.png added

comment:2 by MrPepka, 2 years ago

LSL 1 VGA sometimes when exit from the game ScummVM crashes with error C++.

by MrPepka, 2 years ago

Attachment: ScummVM 8.png added

by MrPepka, 2 years ago

Attachment: ScummVM 9.png added

comment:3 by bonki, 2 years ago

I cannot reproduce these using v2.0.0 and LSL1VGA (English, GOG) so it's possible that only the Polish (and possibly other non-English) version(s) is (are) affected.

comment:4 by bonki, 2 years ago

Summary: Series LSL crashesSCI: Various crashes in LSL1 (Polish)

comment:5 by sluicebox, 3 months ago

There are (at least) two different bugs being reported here.

The first is a random crash when exiting the game, which is bug #10374 and I fixed in February.

The second is a font resource seek error when drawing certain Polish strings. That is still a problem but I now have these game versions and can reproduce this. KQ5 Polish is also affected. I should be able to take a closer look in the near future.

comment:6 by sluicebox, 3 months ago

Summary: SCI: Various crashes in LSL1 (Polish)SCI: Font errors in Polish games

The font error in KQ5, LSL1VGA, LSL5, and LSL6 is a ScummVM bug and is now fixed: ec4bce9c2fc857bd3514d37771b97391a67b0f5c

LSL2 and LSL3 still throw a font error but this is an unrelated issue. Those two games have fonts that appear corrupt. SCI Companion errors and SCI Viewer crashes when loading them. Sierra's interpreter works though so we'll need to figure out why that is.

comment:7 by sluicebox, 3 months ago

Owner: set to sluicebox
Resolution: fixed
Status: newclosed

LSL2 and LSL3 fonts fixed in: 80d870e24956e536001e88e0e1873a2f36e3622d

You will have to remove and re-add LSL2 and LSL3 to ScummVM so that they are detected as Polish in order for the fixes to be applied.

Last edited 3 months ago by sluicebox (previous) (diff)
Note: See TracTickets for help on using tickets.