#10495 closed defect (fixed)

TINSEL: DW1: Prunes disappear if used without putting in inventory

Reported by: sluicebox Owned by: dreammaster
Priority: normal Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

I assume this is a bug in the game scripts. If you pickup the prunes at the university and go to the fish monger and put them in the caviar without first putting them in the luggage or on your person then the prunes disappear from the game, otherwise they would remain where you put them. This dead-ends the game if you didn't first put the octopus and custard pie in the outhouse (i love this sentence) because you're then unable to try again. Unless you'd already played before, you almost certainly need to try again.

That may sound like a convoluted example but it happened to me when playing (I hadn't played the game before) and it took a while to figure out that it was a bug and replay. I bet it happens to others because at the point that you complete the puzzle to get the prunes you likely have an idea of what to use them for and go straight there to try. Or maybe the game is just full of inventory bugs like this?

English CD-ROM version on nightly build on Win7x64

Save game attached at the bag of prunes.

Attachments (1)

dw-cd.017 (4.4 KB ) - added by sluicebox 19 months ago.

Download all attachments as: .zip

Change History (3)

by sluicebox, 19 months ago

Attachment: dw-cd.017 added

comment:1 by sluicebox, 19 months ago

forgot to add reproduction steps for saved game:

  1. pick up prunes
  2. exit to map by clicking door with prunes icon
  3. go to street (still with prunes icon)
  4. walk to fish monger and click prunes on caviar
  5. prunes are now gone and not in luggage or rincewind

comment:2 by dreammaster, 19 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

I've implemented what I think is a clean patch for the problem.. if an item is being released from being held by the scripts that has never been in either Rincewind or the Luggage's inventory, it'll automatically get dropped into the Luggage.

Note: See TracTickets for help on using tickets.