Opened 4 years ago

Closed 18 months ago

Last modified 18 months ago

#10473 closed defect (duplicate)

SCUMM: COMI - Barbery Coast theme starts before the introductory theme finishes

Reported by: AndywinXp Owned by: AndywinXp
Priority: normal Component: Engine: SCUMM
Version: Keywords: imuse digital
Cc: Game: Monkey Island 3

Description

Hello,
to reproduce this, you simply have to go to the Barbery Coast for the first time.
In the original exe (as you can hear here: https://youtu.be/YsLPOrRitz0?t=52m16s ) during the first (automatic) dialog, the iMUSE plays the file 2232-A~1.IMX (cue "ArriveBarber"), and when it finishes it switches to the Barber Shop theme (file 1285-B~1.IMX).

In ScummVM (2.0.0, Windows 10 64-bit, english game) the main Barber Shop theme starts a lot earlier than expected, interrupting the ArriveBarber cue.

Attachments (1)

comi.s29 (81.1 KB ) - added by AndywinXp 4 years ago.
Savegame

Download all attachments as: .zip

Change History (6)

by AndywinXp, 4 years ago

Attachment: comi.s29 added

Savegame

comment:1 by digitall, 4 years ago

Keywords: has-pull-request added

comment:2 by digitall, 3 years ago

Keywords: has-pull-request removed

The fix proposed in the pull request 1196 by amending the entry in the digital imuse table, _comiSeqMusicTable[] does not match the script / code disassembly, so the root cause will take further investigation and comparison with the original interpreter...

Last edited 3 years ago by digitall (previous) (diff)

comment:3 by raziel-, 22 months ago

Summary: COMI: Barbery Coast theme starts before the introductory theme finishesSCUMM: COMI - Barbery Coast theme starts before the introductory theme finishes

comment:4 by AndywinXp, 18 months ago

Owner: set to AndywinXp
Resolution: fixed
Status: newclosed

Whoops, duplicate of #4635 discovered only after 3 years, good job, me!
Anyway, fixed in 924a62b40b271f065528f68fa86a28dcb0d0f9a6.

comment:5 by AndywinXp, 18 months ago

Resolution: fixedduplicate
Note: See TracTickets for help on using tickets.