#10472 closed defect (fixed)

MOHAWK: MYST: Initial flyover of Myst Island shown before the Myst book opens

Reported by: vonLeheCreative Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Myst

Description

  • ScummVM version: 2.0.0
  • Language of game: English
  • Version of game: Myst v1.0 (Windows CD-ROM)
  • My OS: Windows 10

Repro steps:

  • Watch the intro sequence with the falling Myst book next to the credits
  • After the book lands on the ground, click on it

Expected:
Large version of book is shown. I'm not sure if it's supposed to open only when I click on it once more, or automatically at this point. Either way, once it opens, the video showing the flyover of Myst Island should play.

Actual:
The flyover video begins playing as soon as the large version of the book appears, before it opens.

Attachments (1)

VideoOutsideBook.png (69.0 KB ) - added by vonLeheCreative 20 months ago.
Shows the Myst flyover video appearing before the Myst book is open.

Download all attachments as: .zip

Change History (4)

by vonLeheCreative, 20 months ago

Attachment: VideoOutsideBook.png added

Shows the Myst flyover video appearing before the Myst book is open.

comment:1 by bgK, 20 months ago

Summary: Initial flyover of Myst Island shown before the Myst book opensMYST: Initial flyover of Myst Island shown before the Myst book opens

Your version of Myst does not seem to be known to ScummVM. ScummVM should display some warnings about it when starting the game. Would you mind opening another ticket with the detection information?

comment:2 by bgK, 20 months ago

Summary: MYST: Initial flyover of Myst Island shown before the Myst book opensMOHAWK: MYST: Initial flyover of Myst Island shown before the Myst book opens

comment:3 by bgK, 20 months ago

Owner: set to bgK
Resolution: fixed
Status: newclosed

Thanks for your report. It seems like that early version of Myst has slightly different script data for the Myst flyby video. I've applied a patch in ScummVM so the "play on card change flag" value matches newer releases, fixing the bug.

Daily builds as of 2.1.0git-1639 should be fixed.

Note: See TracTickets for help on using tickets.