#10456 closed defect (fixed)

XEEN: world status not properly reset when quitting to main menu and starting a new game

Reported by: darkstar Owned by: dreammaster
Priority: normal Component: Engine: Xeen
Keywords: Cc:
Game: Might and Magic: World of Xeen

Description

When quitting to main menu and starting a new game, the status of the world (killed monsters, searched locations, minimap, probably other stuff too) is not properly reset.

Change History (3)

comment:1 by dreammaster, 20 months ago

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

This should be fixed now. I independently discovered that I wasn't flushing the cached set of modified resources from the current game when loading a new savegame, so it kept using them.

comment:2 by darkstar, 20 months ago

Resolution: fixed
Status: closednew

reopening due to not being fixed.

To reproduce: Start ScummVM, start a new game, kill the slime, move forward a few steps, quit to main menu and immediately start a new game again. Notice the slime is missing and the automap already has the few steps taken earlier "discovered"

comment:3 by dreammaster, 20 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.