Opened 20 months ago

Closed 4 months ago

Last modified 3 months ago

#10432 closed defect (fixed)

WME: Carol Reed Mysteries hint system not working

Reported by: albadross Owned by: lolbot-iichan
Priority: normal Component: Engine: Wintermute
Keywords: has-pull-request Cc:
Game: Wintermute

Description

The more recent Carol Reed Mystery games (since 05 - The Colour Of Murder and to date up to 13 - The Birdwatcher) have introduced a hints system (using a file called hints.csv). These work fine running the Wintermute games stand-alone. Could they be made to work under the ScummVM WME engine as well?

Change History (8)

comment:1 by tobiatesan, 15 months ago

Thanks for reporting, the CR games are my all-time WME favourite.

I am not promising anything, but I'll try to have a look sometime during the next month.

comment:2 by albadross, 15 months ago

To be honest, I have completed all the CR games using ScummVM Wintermute without needing any help. But when I finished them, I looked at the datafiles for the games and found they had a file called hints.csv. I thought that was odd because I have had never seen any hints whilst playing.

Sure enough, when I started playing a couple of the games directly (without ScummVM), the hints appeared.

I am really pleased that someone is taking an interest in the Wintermute engine again. It seems to me to be a really under-rated resource for ScummVM - I have completed more than 30 Wintermute 2D adventures (of varying lengths) using it.

comment:3 by lolbot-iichan, 14 months ago

Game: Wintermute

comment:4 by lolbot-iichan, 4 months ago

Owner: set to somaen
Resolution: fixed
Status: newpending

I hope I have fixed this with https://github.com/scummvm/scummvm/pull/1685

comment:5 by Filippos Karapetis <bluegr@…>, 4 months ago

In a7efc8a:

WINTERMUTE: Fix Split() method of ext_string

It's hard to believe, but this fixes bug "#10432" WME Carol Reed
Mysteries hint system not working.

Carol Reed hint system happen to heavily use line.Split(";") results,
which were wrong by 1 byte (delimeter was appended to result while it
shouldn't be).

I started with decompiling Carol Reed source code, reproducing issue
with a stand-alone test project (which worked with WME and showed [null]
with ScummVM). then minimized it to a minimal testcase:

var line = new String("New Goal;Visit Christina at the Art
Museum;1;0;S;;");
var ar = line.Split(";");
if((ar[0] == "New Goal")) { var g = ar[1]; }

comment:6 by bluegr, 4 months ago

Owner: changed from somaen to lolbot-iichan
Status: pendingclosed

comment:7 by lolbot-iichan, 3 months ago

Keywords: has-pull-request added
Type: enhancementdefect

comment:8 by lolbot-iichan, 3 months ago

Summary: WME Carol Reed Mysteries hint system not workingWME: Carol Reed Mysteries hint system not working
Note: See TracTickets for help on using tickets.