Opened 16 years ago

Closed 16 years ago

#1043 closed defect (fixed)

Zak: No tram sequence

Reported by: SF/voodoofx Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Zak McKracken

Description

ScummVM version: ScummVM 0.5.0pre-cvs (Jul 17 2003
00:58:07)

platform: win32(WinXP)
Zak version: v2(enhanced)
language: english

Previously this trick would crash ScummVM, but now it
displays black screen until you press ESC. This is the
trick... i've put the Zak in tram on Mars. The
moment "tram leaving in 5 seconds! all aboard!"
dissapears i switch to Annie on Earth. Instead of
the "tram taking zak to mars pyramid" sequence you get
black screen, which you can ESCape in order to return
to the game.

Ticket imported from: #772880. Ticket imported from: bugs/1043.

Change History (4)

comment:1 by fingolfin, 16 years ago

Did you verify this works correctly in the original? (I never played
the original so I simply don't know).

comment:2 by SF/voodoofx, 16 years ago

Well i played the original, but it was like 5 years ago. And i
didn't try this trick, it is possible that the result is same with
original. To bad ScummVM savegames aren't compatible with
it. I don't feel like playing Zak again from the begining, just to
check this, afterall i did complete two versions in these last
days for 0.5.0 release :)

You can close it if you like, since it is not likely anyone will try
this. :) It's just me, since i know Zak inside and out. :)

comment:3 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:4 by Kirben, 16 years ago

I can't reproduce the problem with current ScummVM cvs, the
tram sequence is still always shown. So looks like it has been
fixed...

Note: See TracTickets for help on using tickets.