Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#10424 closed enhancement (fixed)

TUCKER: Add mouse wheel support for inventory scrolling

Reported by: raziel- Owned by: bonki
Priority: low Component: Engine: Tucker
Keywords: Cc:
Game: Bud Tucker

Description

ScummVM 2.1.0git (Feb 3 2018 08:08:42)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG cloud (servers, local)

This is not a bug report, but a feature request.

If it's not taken into consideration, please discard.

In the game there are two different arrows for scrolling inventory objects and saved games.
Those are only usable (in the original engine) by clicking on the arrows (as mouse wheels weren't common at that time).

I'd like to ask if mouse wheel support could be added for those two lists.
imho it would add a great deal of use.

It's not part of the original engine, so i'd understand if it gets rejected, but this kind of support was already added to the Rex Nebular engine/game before and it made the playability so much easier and fun.

Bud Tucker in Double Trouble (DOS/English)

AmigaOS4 - PPC - SDL - BE
gcc (adtools build 5.4.0) 5.4.0

Change History (5)

comment:1 by bonki, 22 months ago

Component: --Unset--Engine: Tucker
Game: Bud Tucker
Priority: normallow
Summary: TUCKER: FR - Add mouse wheel supportTUCKER: Add mouse wheel support for inventory scrolling
Type: defectenhancement

Which other engines (apart from MADS, apparently) have implemented this?

comment:2 by raziel-, 22 months ago

I'm the wrong to ask, i'm afraid.

I only know of the implementation in MADS/Rex Nebular because i did some extensive beta testing for strangerke when he polished the game/engine back then.

comment:4 by bonki, 22 months ago

Owner: set to bonki
Resolution: fixed
Status: newclosed

comment:5 by raziel-, 22 months ago

Awesome...and so fast :-)

Thanks a bunch :-D

Note: See TracTickets for help on using tickets.