#10421 closed defect (fixed)

QFG4: Crash at the end of Tanya's resurrection cut scene

Reported by: darksoul42 Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Quest for Glory 4

Description

On this version of ScummVM :
ScummVM 2.0.0 (Dec 26 2017 20:39:13)
Features compiled in: Vorbis MP3 ALSA SEQ sndio TiMidity RGB zLib MPEG2 Theora FreeType2 JPEG PNG

Telling Tanya about the staff of Erana (after getting the info about the Destiny Spell from the Gypsy Fortune Teller) does start the cut scene, but it crashes at the end when the hero just receives the staff.

Here is the error message displayed :

ERROR:
parameter 0: 0001:46c4 (object), should be object
parameter 1: 0000:0000 (null, integer), should be null, integer
parameter 2: 0000:0006 (integer), should be null, integer
parameter 3: 0000:000b (integer), should be null, integer
parameter 4: 0001:46c4 (object), should be null, integer
[VM] kDoSound(Fade): signature mismatch in method longSong2::fade (room 270, script 64989, localCall ffffffff)!

This is a show stopper since it prevents the player from finishing the game.

Attachments (2)

qfg4-cd.018 (80.5 KB ) - added by darksoul42 21 months ago.
Tell Tanya about Erana's Staff to trigger a crash after the cut scene
qfg4-cd.001 (69.8 KB ) - added by darksoul42 14 months ago.
Tanya resurrection cut scene right before crashing

Download all attachments as: .zip

Change History (5)

by darksoul42, 21 months ago

Attachment: qfg4-cd.018 added

Tell Tanya about Erana's Staff to trigger a crash after the cut scene

comment:1 by bluegr, 14 months ago

Thanks for your report! Unfortunately, the saved game looks to be from an earlier stage, before learning about the staff of Erana from the Gypsy Fortune Teller, as I don't see that option when talking to Tanya.

Could you upload the correct saved game please?

comment:2 by darksoul42, 14 months ago

Huh, that's really strange, I just retried this savegame after downloading it, copying it on a clean setup of QfG4 CD, ran it with ScummVM 2.1.0git2276-gd433aedf37, and I did have that option show up. Just in case, I created an extra save with the cut scene started.

by darksoul42, 14 months ago

Attachment: qfg4-cd.001 added

Tanya resurrection cut scene right before crashing

comment:3 by bluegr, 14 months ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

Great! I was able to reproduce the bug with that save. Thanks for your report! This script bug has now been resolved in commit 380551ed8e8ddbe173bcea765e9b74c8af865610.

Note: See TracTickets for help on using tickets.