Opened 16 years ago

Closed 16 years ago

Last modified 7 months ago

#1042 closed defect (fixed)

Compilation problems with debian 3.0 (linux)

Reported by: SF/fred19726 Owned by: fingolfin
Priority: normal Component: Port: Linux
Keywords: Cc:
Game:

Description

Hi,

I run debian 3.0 with the default compiler (gcc/cpp 2.95)

I have experienced some compilation problems with
scummvm 0.5.0 pre (20030716).

When i run make (after configure) i get this message:

cc1plus: Invalid option `-Wdisabled-optimization'
make: *** [backends/sdl/sdl-common.o] Fehler 1

After removing "-Wdisabled-optimization" from the
Makefile i can compile scummvm succesfully but there
are many warnings like this:

In file included from common/list.h:25,
from common/config-file.h:28,
from common/engine.cpp:23:
/usr/include/assert.h:70: warning: redundant
redeclaration of `__assert_fail(const char *, const
char *, unsigned int, const char *)' in same scope
/usr/include/assert.h:70: warning: previous declaration
of `__assert_fail(const char *, const char *, unsigned
int, const char *)'
/usr/include/assert.h:76: warning: redundant
redeclaration of `__assert_perror_fail(int, const char
*, unsigned int, const char *)' in same scope
/usr/include/assert.h:76: warning: previous declaration
of `__assert_perror_fail(int, const char *, unsigned
int, const char *)'
/usr/include/assert.h:82: warning: redundant
redeclaration of `__assert(const char *, const char *,
int)' in same scope
/usr/include/assert.h:82: warning: previous declaration
of `__assert(const char *, const char *, int)'

O.K. but scummvm seems to work (i tested it with comi)

n.b.: when i run "make deb" the Debian package has a
bad name: "scummvm-cvs_0.5.0pre-cvs;20030716-1_i386.deb"

Ticket imported from: #772559. Ticket imported from: bugs/1042.

Change History (3)

comment:1 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:2 Changed 16 years ago by fingolfin

I added -Wdisabled-optimization into the "GCC 3.x only" list of
warnings.
The other warnings are caused by -Wredundant-decls; they really
are there because your system headers are "bad" (they don't
protect themselves against multiple includes / multiple
declarations), but since we can live without that warning, I
disabled it by default for now, too.

comment:3 Changed 7 months ago by digitall

Component: Port: Linux
Note: See TracTickets for help on using tickets.