#10406 closed defect (fixed)

TITANIC: Stuck in Barbot loop

Reported by: bosjox Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

Scummvm version: 2.0.0
Game version: CD, v1.00.42
OS version: Win7-64

Description: When loading the attached saved game, I am stuck with a looping bar bot. I can "talk" to it, click the bell, listen to the annoying parrot (I even tried calling the bell bot; no change), but as soon as I try to leave the bar by clicking the left or right arrow, the program hangs, showing the hourglass. The parrot is still talking, though. The keyboard is not working, so the only way out is to close Scummvm.

This may or may not be related to the fact that the bar bot does not seem to accept the starling puree I offered it. I have not seen this before, but as the bot says something like "I thought that was starling puree, but with my luck it probably wasn't" I probably need to check his settings before giving him the puree next time. He does also give me a new glass, which surely indicates that it for some reason has not accepted the puree as such. (I have also given him the TV and the lemon.)

Also, the loop seems a bit short – after rotating at the front desk, the bot jumps to the back; I don't remember that happening in the original version.

Attachments (1)

titanic-win.002 (105.0 KB ) - added by bosjox 21 months ago.
Saved game: causes hanging in bar

Download all attachments as: .zip

Change History (8)

by bosjox, 21 months ago

Attachment: titanic-win.002 added

Saved game: causes hanging in bar

comment:1 by dafioram, 21 months ago

Summary: Titanic: Hanging in the bar...TITANIC: Stuck in Barbot loop

Thanks for your report.

Do you know how you got the barbot to get stuck in this loop? Do you have a saved game right before with steps to make him get stuck in the loop?

You may have to say something in particular to get him to accept the pureed. He will give the glass back even if you give him the right thing(s), but don't do the right thing(s). You can get more if need be.

comment:2 by bosjox, 21 months ago

Unfortunately the only saved games I have before this one are quite a long time before, several hours of unstructured play.

I suppose the starling puree is a red herring; I probably didn't type the required words fast enough, or when all the settings of the bot where in the red, or something -- sometimes it is difficult to understand the logic behind this game...

I ran the game again, and got beyond the bar bot without too much problem, so I suppose this is a pure savegame problem. The loop might be a clue; in this second run, the bot "looped" quite normally between the front and the back, and when I clicked left or right arrow to leave the bar, it exited the loop and went left, during which time the hour glass is shown. It seems there is something funny with the loop after the saved game is loaded, so that the bot never exits its loop.

comment:3 by dafioram, 13 months ago

Owner: set to dreammaster

@dreammaster I have been able to reproduce barbot looping issues when the game is saved while in front of the barbot specifically when he starts to move a little.

Would it be possible to disable saving when the barbot is in front of the player or even more precise when the barbot starts to do an animation?

comment:4 by dreammaster, 13 months ago

Not a bad idea; it would ensure that noone else suffered the problem. Though for consistency it would probably be better to disabling saving all the time for that particular view. Like how saving is disabled in the closeups for the various cell point settings artworks.

comment:5 by dreammaster, 13 months ago

Well.. that didn't work. To reuse the same code as for the cell point settings closeups, I'd have to lock the PET to it's currently active tab - this is how the game prevents users from switching to the PET tab in the original interpreter and saving the game. Maybe I can implement a post-load message handler for the Barbot to reset his animation back to idle, to work around the problem. I'll have to experiment on the weekend

comment:6 by dafioram, 13 months ago

I cannot reproduce this issue in the original game.

comment:7 by dreammaster, 13 months ago

Resolution: fixed
Status: newclosed

Finally tracked down the cause of the problem, and properly fixed it.

Note: See TracTickets for help on using tickets.