#10392 closed defect (fixed)

SCI: PQ4: stopping with debugging console in front of kitty club

Reported by: windlepoons Owned by: dafioram
Priority: blocker Component: Engine: SCI
Keywords: sci32 Cc:
Game: Police Quest 4

Description

Game: Police Quest IV: Open Season (CD/DOS/German)
OS: Siduction 64bit
ScummVM: 2.1.0git209-gd6078ea

If I want to go to the Kitty club, then opens debugging console of ScummVM.
I can not continue playing.

User picked target 'pq4-cd-de' (gameid 'sci')...
  Looking for a plugin supporting this gameid... SCI [SCI0, SCI01, SCI10, SCI11, SCI32]
  Starting 'Sierra SCI Game'
Script-Patcher: 8 bit selector required, game uses 16 bit selector
Faulty signature: 'fix missing points showing barbie the red shoe'!

is this related to #9849?

Save game was added.

Attachments (3)

pq4-cd-de.040 (65.5 KB) - added by windlepoons 15 months ago.
before the Kitty club
pq4-cd.001 (60.5 KB) - added by dafioram 15 months ago.
before the bitty kitty club
walkthrough.txt (405 bytes) - added by dafioram 15 months ago.
This is a walkthrough for this section

Download all attachments as: .zip

Change History (7)

Changed 15 months ago by windlepoons

Attachment: pq4-cd-de.040 added

before the Kitty club

comment:1 Changed 15 months ago by dafioram

Keywords: sci32 added
Priority: normalblocker

Bug is also present in english version.

comment:2 Changed 15 months ago by dafioram

The issue is not due to commit 4d7d769, I checked it in 1.10.0git-4362-g9c4316b.

Git blame shows that c5dce17b1f1392feb8825aba5addbc3999eeaa51 may be the culprit.

comment:3 Changed 15 months ago by dafioram

PR1107

Changed 15 months ago by dafioram

Attachment: pq4-cd.001 added

before the bitty kitty club

Changed 15 months ago by dafioram

Attachment: walkthrough.txt added

This is a walkthrough for this section

comment:4 Changed 14 months ago by csnover

Owner: set to dafioram
Resolution: fixed
Status: newclosed

Thanks for your report! A patch for this issue has been added in commit 9518fd7210a371ded3a482acbcb34777fd6dd51c and will be available in daily builds 2.1.0git-266 and later.

Note: See TracTickets for help on using tickets.