Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#10389 closed defect (fixed)

MOHAWK: Riven: Boiler FMV Skip Issue

Reported by: deanff Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Riven

Description

Riven has an issue when skipping FMVs multiple times.

After the second skip, the FMV does not play.

Below is a video of the problem:
https://www.youtube.com/watch?v=ZVjfcSnlQ5E

ScummVM Version: 2.1 and early versions.
Game Language: English
Game Version: CD and DVD from GOG.com
My OS: Windows 10 build 1709 64-bit

Change History (3)

comment:1 by dafioram, 22 months ago

Keywords: fmv skip removed
Summary: Riven - FMV Skip IssueMOHAWK: Riven: Boiler FMV Skip Issue

Thanks for your report!

ScummVM is doing something different for this water pipe than the original.

If I play through the cd or dvd version in the original interpreter it is immediately responsive, if I skip this FMV once, twice, or a bunch of times.

If I play the dvd or cd version in scummvm and do two skips for the water pipe fmv from turning the wheel then there is a long delay where I have cursor control, but before I can turn the wheel again. Unless I change views and back. I think the delay in the cd version might be longer than the dvd version. The delay is about 10 seconds.

deanff,

Have you seen this issue for other FMVs or just this one?

comment:2 by bgK, 22 months ago

Owner: set to bgK
Resolution: fixed
Status: newclosed

Thanks for your report. I've not been able to reproduce the issue with the boiler, but some other videos showed the issue you describe. I've pushed a fix as commit cf1171d. Please reopen this ticket is the issue remains with the next daily build (2.1.0git-210 and up).

comment:3 by deanff, 22 months ago

You are an absolute legend, bgK!

Just tested the new Kirben build using Riven CD and DVD versions.

The issue is no longer present.

@dafioram - The issue affected some other FMVs as well. Like opening the Dragon Mouth from the outside on Jungle Island, and pulling the lever for the submarine (also on Jungle Island). However, both of these issues have now been resolved. :)

Note: See TracTickets for help on using tickets.