Opened 2 years ago

Closed 5 weeks ago

#10352 closed defect (invalid)

MOHAWK: Riven: Key mapping can't rattle locked gate on exit.

Reported by: macca8 Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Riven

Description

This report refers to using keyboard navigation to enter & exit the locked gate on Temple Island.

The expected behaviour is the same regardless of which side of the gate (inside or outside) the player is standing… the 'Up arrow' key (forward) should rattle the gate, and the 'PageDown' key (look down) should select the space below the gate to allow the player to pass through.

This works as expected when the player is outside, but not when inside the tunnel looking out through the gate.

In this case, the 'Up arrow' key selects the space below the gate, and the 'PageDown' key does nothing. It's not possible to rattle the gate (except by using the mouse).

To reproduce, using the attached saved game, click the relevant keys while facing the gate.

Current Daily Build: 2.1.0git4-g2ca0235 (30 November 2017)
Game Version: English, 5-CD (contains v1.02 patch files)
Platform: Intel Mac (OS X 10.6.8)

Attachments (1)

riven-009.rvn (17.7 KB ) - added by macca8 2 years ago.
Backside of Temple Island's locked gate.

Download all attachments as: .zip

Change History (4)

by macca8, 2 years ago

Attachment: riven-009.rvn added

Backside of Temple Island's locked gate.

comment:1 by bgK, 5 weeks ago

Owner: set to bgK
Resolution: invalid
Status: newpending

This is intended behavior. When the player is inside the cave, we know they understand it is possible to go under the gate. There is no need for going outside of the cave to me more complicated than necessary.

comment:2 by macca8, 5 weeks ago

Thanks for the reply. Makes sense.
I don't see any point in keeping this open.

comment:3 by bgK, 5 weeks ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.