Opened 15 months ago

Closed 14 months ago

Last modified 4 months ago

#10340 closed defect (fixed)

PS3: Freeze Playing COMI

Reported by: kintera Owned by: bgK
Priority: normal Component: Port: PS3
Keywords: Cc:
Game: Monkey Island 3

Description

Upon playing through the game I have noticed, the PS3 port of Scumm upon asking for the Lost Welshman for a ride to skull island after giving the compass to him, upon entering the cut-scene the game will promptly freeze.

I have tested the 1.9.0, Latest stable build 1.9.1pre39-g483d123 from build bot, latest Devbuild will currently crash upon starting on the PS3, and all have the issue minus the DEV build which will not start. On a PS3 with Rebug 4.81.2

This issue is not scene on the PC with the same game files and using the save from the PS3 and can continue forward on the PC.

I have attached a save file at right before the freeze, all one has to do is hand over the compass to Welshman and request passage to skull island.

Attachments (1)

comi.s05 (118.4 KB) - added by kintera 15 months ago.

Download all attachments as: .zip

Change History (8)

Changed 15 months ago by kintera

Attachment: comi.s05 added

comment:1 Changed 15 months ago by csnover

Component: Engine: SCUMMPorts
Keywords: PS3 port removed
Summary: Freeze Playing COMI on PS3 portPS3: Freeze Playing COMI

comment:2 Changed 15 months ago by kintera

Also happens again upon returning from skull island, upon the end of the conversions and the Welshman leaves, it seems the trigger for the rowing cut-scene has an issue or the playing of this cutscene.

comment:3 Changed 15 months ago by bgK

Very curious. I was able to reproduce it with your save on my PS3. The XMB appears when pressing the PS button on the controller. Pressing it again closes the XMB, and the cutscene resumes as if nothing happened.

comment:4 Changed 15 months ago by kintera

Just tested that, it does seem to be a work around. Just going to the XMB and Back hmm...

comment:5 Changed 15 months ago by bgK

What happens is the game warps the mouse cursor outside of the window using very large coordinates (possibly to hide it during the cutscene). Moving the mouse outside of the window is otherwise not possible on the PS3, since there is always only one fullscreen window.
The issue is that gaining and losing mouse focus is used as a signal by SDL that the XMB is going to open/close and that ScummVM should pause/resume the game...

I've changed the way SDL notifies ScummVM about the XMB status to not misuse mouse focus. However, it requires updating SDL on buildbot which will take some time since I don't have access to the server.
In the meantime, here is a fixed build (scumm engine only): https://filenurse.com/download/e011d4aa696bdd9028b43cf5072770eb.html.

comment:6 Changed 14 months ago by bgK

Owner: set to bgK
Resolution: fixed
Status: newclosed

A fix was implemented in revision 6437ca1. Buildbot was not updated, PS3 builds are not working.

comment:7 Changed 4 months ago by digitall

Component: PortsPort: PS3
Note: See TracTickets for help on using tickets.