Opened 16 months ago

Closed 11 months ago

Last modified 4 months ago

#10334 closed defect (duplicate)

CMD: Strange behaviour when trying to launch a game by gameid

Reported by: raziel- Owned by: bonki
Priority: normal Component: --Other--
Keywords: Cc:
Game:

Description

ScummVM 2.0.0git (Nov 26 2017 14:31:52)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG cloud (servers, local)

I get a strange behaviour which i think might be a bug (but i'm not sure).

Steps to reproduce: (at least what i did)
You need some games installed and have a scummvm.ini ready.

1) Go to your console
2) Type "scummvm indy3" to start your game, *BUT* make sure that your game ID is different, .e.g.

My (only) entry for Indiana Jones III looks like this

[indy3-fm]
description=Indiana Jones and the Last Crusade (FM-TOWNS/English)
path=Games:GamesVM/Lucas Arts/Indiana Jones/The Last Crusade
gameid=indy3
language=en
platform=fmtowns
guioptions=sndNoSpeech sndNoMIDI midiTowns noAspect lang_English

(Yeah, thank you, it *did* cost a little fortune on eBay) :-)

2) Typing the wrong gameid ("indy3" instead of "indy3-fm"), leads to scummvm printing following message in console:
User picked target 'indy3' (gameid 'indy3')...

Looking for a plugin supporting this gameid... SCUMM [all games]
Starting 'Indiana Jones and the Last Crusade'

WARNING: SCUMM [all games] failed to instantiate engine: Path does not exist (target 'indy3', path')!

Which is true, because i don't have an entry called "indy3" and as such no path configured.

Now comes the weird part.

4) I get a little window in which it tells me:
Error running game: Path does not exist

and after that i'm thrown into the LAUNCHER (which i didn't want in the first place)

5) Now scroll either down to your original game entry and or see instantly that scummvm has magically added a new entry to the game's list (in my case) called "Indy3" (which is set to default everywhere when looking at it with "Edit Game"*).

Well, i didn't want it to create a nerw entry and i didn't want to end up in Launcher again.

Those are two misbehavings which needs to be fixed imho.

The new entry is NOT saved btw. If i Quit the Launcher it won't be available in scummvm.ini.

* The same action leads to a crash in ResidualVM btw, but i'll create a bug report there aswell

AmigaOS4 - PPC -SDL - BE
gcc (adtools build 5.3.0) 5.3.0

Change History (3)

comment:1 Changed 11 months ago by bonki

Summary: LAUNCHER/CONSOLE: Misbehaving/Strange Behaviour when using wrong game IDCMD: Strange behaviour when trying to launch a game by gameid

This appears to be a duplicate of #2788.

comment:2 Changed 11 months ago by bonki

Owner: set to bonki
Resolution: duplicate
Status: newclosed

Yep, definitely a duplicate. SCUMM still suffers from this old bug because the fix only targets the advanced detector which SCUMM doesn't use.

Thanks for reporting this!

comment:3 Changed 4 months ago by digitall

Component: --Unset----Other--
Note: See TracTickets for help on using tickets.