Opened 3 years ago

Last modified 2 months ago

#10333 new defect

BACKENDS: Android - Unable to browse the storage

Reported by: spinktvis Owned by:
Priority: normal Component: Port: Android
Keywords: Cc: antoniou79
Game:

Description

With the November 24 android mt-32-sci-scumm-mohawk debug build I've got a storage bug.

I'm unable to browse the storage from the add game menu in ScummVM.

Attached log and screenshot.

Attachments (5)

Screenshot_20171125-215422.png (46.0 KB ) - added by spinktvis 3 years ago.
scummvm-2017-11-25-21-52-35.txt (19.9 KB ) - added by spinktvis 3 years ago.
scummvm-2017-12-01-21-32-36.txt (66.0 KB ) - added by spinktvis 3 years ago.
Screenshot_20171201-223250.jpg (209.8 KB ) - added by spinktvis 3 years ago.
Screenshot_20171201-224919.jpg (398.5 KB ) - added by spinktvis 3 years ago.

Download all attachments as: .zip

Change History (20)

by spinktvis, 3 years ago

by spinktvis, 3 years ago

comment:1 by csnover, 3 years ago

Does it work with nightly builds? What version of Android are you using? What steps are needed to reproduce the problem?

comment:2 by csnover, 3 years ago

Keywords: Android storage removed

comment:3 by dafioram, 3 years ago

ScummVM: Android-arm ed638bac (11/27/2017)
Device: Tablet Tf201
OS: Android 4.1.1

My device is rooted so it is no big deal for me. When you start scummvm-gui up and you click add game it starts in "/", root, so the user if they are not on a rooted device then they won't have access to "/" so it does not let them see any folders there.

Somehow scummvm needs to start in the sdcard area that the user does have read/write access to.

comment:4 by spinktvis, 3 years ago

Just flashed the OOS 8.0 open beta build (Oneplus Oreo android firmware). Currently at work, so I'll test once I get home, I'll have to reinstall all my apps.

comment:5 by dafioram, 3 years ago

This bug is similar to #9621, although I think that one only affected Android 7.0 users.

comment:6 by spinktvis, 3 years ago

I tried the November 24 build on Android 7.1.2.

Just tested with the November 30 2017 buildbot arm build. Android 8.0.0. Same problem.

Steps to reproduce:
Install ScummVM, launch ScummVM, click add game, unable to browse SD card.

I have magisk installed for root.
My default sdcard path is storage/emulated/0
That's for both Android 7.1.2 and 8.0.0
I've attached a new log.

by spinktvis, 3 years ago

comment:7 by spinktvis, 3 years ago

Just adding that the 1.9.0.1 beta build linked here http://forums.scummvm.org/viewtopic.php?t=14364 doesn't have this problem. I can restore it with titanium backup and it works great.

comment:8 by dafioram, 3 years ago

On your rooted phone are you able to access the contents of the root folder via a folder program like ES File Folder?

Also has the scummvm program be granted superuser (or the equivalent in magisk)?

comment:9 by spinktvis, 3 years ago

Yes, I'm able to browse the storage with a file browser. Screenshot attached.

Screenshot attached of 1.9.0.1 beta build where I'm able to browse my storage.

ScummVM requests superuser permissions, I've been using ScummVM on Android since Android 4.x

by spinktvis, 3 years ago

by spinktvis, 3 years ago

comment:10 by csnover, 3 years ago

I hope this doesn’t come off as rude, but would you guys mind taking the troubleshooting to a different forum? I get an email notification every time there is a response, attachment, etc. and it is filling up my inbox.

Plainly, ScummVM should not be defaulting the file browser to a directory that requires rooting the device, so that needs to be fixed regardless of whether or not you can get access. As such, there’s no need to try to figure out why it works with root on some devices but not others, since ScummVM is broken no matter what here and needs to be fixed.

Thanks!

comment:11 by digitall, 2 years ago

Component: PortsPort: Android

comment:12 by ccawley2011, 12 months ago

Resolution: fixed
Status: newclosed

comment:13 by sev-, 12 months ago

Resolution: fixed
Status: closednew

In fact, that is a fix for a different problem. Reopening.

comment:14 by antoniou79, 12 months ago

Cc: antoniou79 added

comment:15 by raziel-, 2 months ago

Summary: ANDROID: Unable to browse the storageBACKENDS: Android - Unable to browse the storage
Note: See TracTickets for help on using tickets.