Opened 16 years ago

Closed 16 years ago

#1032 closed defect (fixed)

ZAK: Zak without a body

Reported by: SF/voodoofx Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

ScummVM version: ScummVM 0.5.0pre-cvs Built on Jul
15 2003 11:47:01

Platform: win32(WinXP)
Zak version: EGA(V2 enhanced)
Language: english

When you return control from bird back to Zak, he loses
his body :), leaving him just with his head floating in the
air. Funny as hell :)

Ticket imported from: #771508. Ticket imported from: bugs/1032.

Attachments (3)

zak8.JPG (62.5 KB ) - added by SF/voodoofx 16 years ago.
Zak lost his body
zak.s28 (53.1 KB ) - added by SF/voodoofx 16 years ago.
Zak lost his body - savagame
zak64.s45 (51.3 KB ) - added by Kirben 16 years ago.
V1 zak save, jump down and watch sequence to see problem

Download all attachments as: .zip

Change History (10)

by SF/voodoofx, 16 years ago

Attachment: zak8.JPG added

Zak lost his body

comment:1 by fingolfin, 16 years ago

Can you attach a savegame?

comment:2 by fingolfin, 16 years ago

Summary: Zak: Zak without a bodyZAK: Zak without a body

comment:3 by SF/voodoofx, 16 years ago

i sure can, all you need is to push "To Zak" and wait till he
stands up

by SF/voodoofx, 16 years ago

Attachment: zak.s28 added

Zak lost his body - savagame

comment:4 by Kirben, 16 years ago

An easy way to reproduce problem near start of game is to
open and drop into hole to secret chamber below Zak's
bedroom. Zak will be shown with no body just as person
comies to investigate the noise.

by Kirben, 16 years ago

Attachment: zak64.s45 added

V1 zak save, jump down and watch sequence to see problem

comment:5 by Kirben, 16 years ago

The problem is caused by cost.reset() in startAnimActor(),
which is called by animateActor() via o2_animateActor().
If I remove that cost.reset() in startAnimActor(), the problem
doesn't occur and costumes still seem to switch fine.
Maybe that call isn't required for version 1-2 games ?

comment:6 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:7 by Kirben, 16 years ago

Just added that change to cvs, I checked several costume
change locations and noticed no problems.

Note: See TracTickets for help on using tickets.