Opened 16 months ago

Last modified 4 months ago

#10309 new defect

SHERLOCK: MIDI - Broken (in-program) sound driver handling

Reported by: raziel- Owned by:
Priority: normal Component: Engine: Sherlock
Keywords: audio Cc:
Game: Sherlock Holmes: Case of the Serrated Scalpel

Description

ScummVM 1.10.0git (Oct 28 2017 00:36:09)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG cloud (servers, local)

I get no sound whatsoever in the game mentioned below.
I didn't change anything in my MIDI settings and the funny thing is that "The Case of the Rose Tattoo" works just fine with the same settings and MIDI (CAMD) playback. As does all other MIDI playing games.

I can't test MIDI with DOSBox as it doesn't feature a CAMD build, but adlib works fine there.

If you need any more info, i'll gladly provide, if possible

The Case of the Serrated Scalpel (DOS/English)

gcc (adtools build 5.3.0) 5.3.0
AmiogaOS4 - PPC - SDL2 - BE

Change History (7)

comment:1 Changed 16 months ago by raziel-

Can someone shed some light, please?

I have the DOS 9 floppy disk version and there is none .mdi (i guess that are the midi files) either with an installed game or on the disks.

Were they supposed to be decrunched and installed by the installer program?

Can anyone give me a list of all the files that are meant to be installed for Serrated Scalpel and show me a way to get them off of my disks?

Installer options i used:
Musical Device: Roland - Sound Device: Adlib
Extended Memory
Save Play Time

Oh and i installed with DosBox because i lack a DOS PC

Thanks

comment:2 Changed 16 months ago by raziel-

Ok, so this is a strange one

I just played around with the settings, trying different things.

I tried <default>...and now it works!? Huh???

I get an error message on start of the game saying;
The selected audio device 'MT-32 Emulator' cannot be used.
See log file for more information. Attempting to fall back to the next available device...

There is nothing on the log, though.

This message comes two times, if i click the first one away.

Now, further on i tried all the audio devices to see which one make it work...and they ALL do (well, nearly)...strange.

I tried
CAMD (my default normally, which refuses to play any sound, with this particular game only)
MT-32 Emulator (see above)

Working
AdLib Emulator (with lower quality and NOT through my MIDI device)

Working, with using my MIDI device (which is even stranger and shouldn't be the case)
PC Speaker Emulator (probably the device the MT-32 Emulator, mentioned above, picks up)
IBM PC Speaker Emulator
Creative Music System Emulator
Amiga Audio Emulator
Apple II GS Emulator (even though it clearly reads out NOT IMPLEMENTED)
FM-Towns Audio
PC-98 Audio

...

So...help???

edit: typos, wording

Last edited 16 months ago by raziel- (previous) (diff)

comment:3 Changed 16 months ago by raziel-

Summary: SHERLOCK: No sound (MIDI, whatsoever) in gameSHERLOCK: Broken (in-program) sound driver handling

Edited the title to better reflect what's going on

comment:4 Changed 10 months ago by bonki

Keywords: audio added

comment:5 Changed 8 months ago by raziel-

Summary: SHERLOCK: Broken (in-program) sound driver handlingMIDI: Broken (in-program) sound driver handling

The same happens with both versions of Laura Bow i'm having (Amiga floppy and DOS floppy).

Confirmed by another user on the forums:
http://forums.scummvm.org/viewtopic.php?t=14651

Changed the title again to make it more general

comment:6 Changed 8 months ago by raziel-

I just finished testing all of my Sierra (nearly all) and Lucas Arts (all) games, together with all other games that use MIDI music.

None other than the two games mentioned above suffer from this bug.

comment:7 Changed 4 months ago by raziel-

Summary: MIDI: Broken (in-program) sound driver handlingSHERLOCK: MIDI - Broken (in-program) sound driver handling
Note: See TracTickets for help on using tickets.