Opened 16 months ago

Last modified 3 months ago

#10299 pending defect (fixed)

BACKENDS: Retropie: SDL Cursor flashes in corner

Reported by: dafioram Owned by: digitall
Priority: normal Component: Ports
Keywords: Cc:
Game:

Description

SDL 2.0.5
Retropie 4.2
ScummVM: 0e44feadb0ed5a39ab3926d837d1d388f931426f (Oct 17th)

When I play scummvm games on my retropie it plays the game at fullscreen and fits the height and adds black letter box to the width to fill the screen.

Previously, it didn't let the cursor out of the game area, but with the latest it does let the cursor into the black letter box area. This also happens when in the scummvm gui.

It shows a different cursor in the black area with the original still at the edge of the game area. Let call this other cursor the black area cursor.

When a game or scummvm-gui is loading it will briefly flash the black area cursor in the top left corner.

I am able to reproduce the cursor going out of the game area on my linux vm, but not the flickering.

Change History (7)

comment:1 Changed 16 months ago by dafioram

Here is a demo: https://streamable.com/ln73m.

As I go left from the gui area to the black letter box you will see the cursor change, but also if you look in the top left corner you will see the cursor also briefly appear in that corner.

On this system this cursor flash happens during game playing when it does transitions or loads.

comment:2 Changed 16 months ago by csnover

Thanks for your report! Could you please try this again with a build 1.10.0git-5266-g3a95213905 or later and let me know if it is still happening? Thanks again!

comment:3 Changed 16 months ago by dafioram

No change.

comment:4 Changed 15 months ago by dafioram

ScummVM: 7689fd7308020aac0bb788cafc524bd7f01077f4

The cursor flashing in the corner still happens, but now the cursor is restricted to the scummvm-gui rendered portion (except the cursor flash in the corner on gui start up). I believe the cursor improvement of it being locked to the gui rendered area comes from d3a831644c7b9a31b2b74824b7638072a6630fda.

But if I still play a game, rama, the cursor is allowed to go outside the game rendered area into the black letter box area.

Note all of this is fullscreen on the rpi.

comment:5 Changed 15 months ago by csnover

From conversations with the rpi port maintainer, this should be fixed by an upstream patch at https://bugzilla.libsdl.org/show_bug.cgi?id=3974.

comment:6 Changed 4 months ago by digitall

Since SDL-2.0.8 has been released as stable, this should be fixed by using this:
https://www.libsdl.org/download-2.0.php

comment:7 Changed 3 months ago by digitall

Owner: set to digitall
Resolution: fixed
Status: newpending

@dafioram: Is this fixed? If not, can you replicate on the stable v2.0.0 release or with one of the nightly builds?

Note: See TracTickets for help on using tickets.