Opened 3 years ago

Last modified 6 months ago

#10254 new defect

SCI: PQ3: Upcoming turns don't update when speeding

Reported by: dafioram Owned by:
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Police Quest 3

Description

Game: PQ3 DOS English 1.0 GOG With NRS removed (Removed 99.scr and 994.scr)
Tester OS: Win7-64
ScummVM: 1.10.0git-5077-g6f163b9 (Sep 29)

When driving fast, at most 100, the signs that tell you the upcoming road won't update to show the new road when you are driving. When on the left side of the map going East this will show me 1st or 2nd as I cross each intersection going east.

If I slow to something <= 60 it updates as expected. It seems to also happen when going north or south. I've only tested this on day 6. To reproduce:

  1. Load save
  2. Start the car and take your first turn left
  3. Take the next left.
  4. Increase speed to 100

It may update the upcoming road from 1st to 2nd, but then it should keep displaying that road as you crossing intersections.

I don't know if this happens in the original.

Demo: https://streamable.com/isgra

Attachments (1)

pq3.065 (42.5 KB ) - added by dafioram 3 years ago.
Day 6 in car 407/460

Download all attachments as: .zip

Change History (8)

by dafioram, 3 years ago

Attachment: pq3.065 added

Day 6 in car 407/460

comment:1 by ZvikaZ, 7 months ago

I have just checked it, with GOG PQ3 (without the .scr files you mentioned), and with older, non-GOG-packaged, and couldn't replicate the issue.

Maybe it's been solved meanwhile?
Please check it again.

comment:2 by dafioram, 7 months ago

It still happens. I just tried it. From the courthouse I went south then I took a right to get onto rose. I went max speed and it displayed 7th then 6th and from then on every new intersection it displayed 6th rather than 5,4,3. I slowed down and it showed 1st but it didn't update the other intersections while I was speeding past.

comment:3 by ZvikaZ, 7 months ago

What's your ScummVM version?

comment:4 by dafioram, 7 months ago

Latest. What steps did you try?

comment:5 by ZvikaZ, 7 months ago

First I followed your instructions in your first reporting.
Now I've tried your latest instructions - loaded the save you've supplied, went to courthouse, got out of the car, returned, drove south, right to rose, max speed, and saw every correct sign until I crashed out of the street :-)

Maybe the problem is in your PQ3 files, and not ScummVM?
Please try with Dosbox.

You said it's GOG - try to download again latest version from GOG.

Last edited 7 months ago by ZvikaZ (previous) (diff)

comment:6 by ZvikaZ, 6 months ago

@dafioram, any updates?

comment:7 by dafioram, 6 months ago

I checked latest on GoG and its still the same as I have. Maybe you arn't going full speed?

Note: See TracTickets for help on using tickets.