#10250 closed defect (invalid)

SCI: PQ3: Bad palette when hit by a car

Reported by: dafioram Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Police Quest 3

Description

Game: PQ3 DOS English 1.0 GOG With NRS removed (Removed 99.scr and 994.scr)
Tester OS: Win7-64
ScummVM: 1.10.0git-5077-g6f163b9 (Sep 29)

Day 1 when you have pulled someone over if you go to talk to them by walking on the left side of the car you will get hit by a car and die. As it is transitioning to a disappointed Jim Walls it will show the previous view with a bad palette.

Attachments (3)

scummvm00005.png (188.8 KB) - added by dafioram 19 months ago.
Expected street palette, with important area highlighted in red
scummvm00003.png (77.1 KB) - added by dafioram 19 months ago.
Actual palette when transition to death screen.
pq3.011 (32.9 KB) - added by dafioram 19 months ago.

Download all attachments as: .zip

Change History (4)

Changed 19 months ago by dafioram

Attachment: scummvm00005.png added

Expected street palette, with important area highlighted in red

Changed 19 months ago by dafioram

Attachment: scummvm00003.png added

Actual palette when transition to death screen.

Changed 19 months ago by dafioram

Attachment: pq3.011 added

comment:1 Changed 19 months ago by m-kiewitz

Owner: set to m-kiewitz
Resolution: invalid
Status: newclosed

This is not a bug.

Sierra changed the palette as well before running the transition, which made the old screen look wrong. They were limited to 256 colors, so there is no way to do it differently unless we go 15/16-bit-color and then it would actually be an enhancement and wouldn't be like the game looked when using the original interpreter. I think wjp actually even did something like this already.

This happens with all transitions. There are some games, that do a transition to a black screen and then transition again from the black screen, which avoids this.

Note: See TracTickets for help on using tickets.