Opened 2 years ago

Closed 2 years ago

#10245 closed enhancement (fixed)

SCI: Unkown SQ3 version

Reported by: darksoul42 Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Space Quest 3

Description

Please, report the following data to the ScummVM team along with name
of the game you tried to add and its version/language/etc.:

{"resource.002", 0, "ceeda7202b96e5c85ecaa88a40a540fc", 720133},
{"resource.003", 0, "ceeda7202b96e5c85ecaa88a40a540fc", 688294},
{"resource.001", 0, "ceeda7202b96e5c85ecaa88a40a540fc", 485059},
{"resource.map", 0, "876445bb0085a62d5966f4153e2ddf52", 5484},

Space Quest III - The Pirates of Pestulon version v1.0P - 1989-03-22
Video Format: VGA
Language: English
SCI Version: 0.000.453

Apart from the warning, there is no problem with the game that I could see.

Attachments (1)

SQ3 About Screen.png (26.3 KB ) - added by darksoul42 2 years ago.
SQ3 About Screen

Download all attachments as: .zip

Change History (4)

by darksoul42, 2 years ago

Attachment: SQ3 About Screen.png added

SQ3 About Screen

comment:1 by darksoul42, 2 years ago

Component: --Unset--Engine: SCI

comment:2 by darksoul42, 2 years ago

This looks a lot like : https://bugs.scummvm.org/ticket/9626#no3

I wonder if this difference is caused by a different format of floppy.
I can't remember for sure since these were bought 30 years ago and I just kept the game installed all this time, but I think I had 5"1/4 floppies, so it's possible there were low density and high density releases.

comment:3 by csnover, 2 years ago

Owner: set to csnover
Resolution: fixed
Status: newclosed

Thanks for your report! The sizes of the resources would certainly seem to indicate that #9626 came on 360K floppies and this one on 720K floppies. Detection table entries have been added in commit 1351189575251a7fd6ebd6af62677e501077a9df and will be available in daily builds 1.10.0git-5070 and later.

Note: See TracTickets for help on using tickets.