Opened 18 months ago

Closed 15 months ago

Last modified 14 months ago

#10243 closed defect (worksforme)

SQ4 PC98 : SJIS font bugs

Reported by: darksoul42 Owned by: m-kiewitz
Priority: low Component: Engine: SCI
Keywords: japanese pc98 font Cc:
Game: Space Quest 4

Description

Sometimes Scummvm will give out "Font does not offer data for .. .." (with what I assume are multibyte SJIS character codes, that are not present in SJIS.FNT)

I have listed up most of them from a playthrough of the game on ScummVM.

When this bug happens, instead of using the pixelated font (for hiragana & katakana), it uses the high-res font for kanji, and it garbles most text except for katakana.

It should be noted this does not prevent a full playthrough of the game.

Attachments (2)

SQ4 PC98 SJIS bugs.txt (18.8 KB) - added by darksoul42 18 months ago.
List of SJIS font errors given by ScummVM and of how/when to trigger them
SQ4 PC98 SQXII Japanese (Font Bug).png (59.8 KB) - added by darksoul42 18 months ago.
Missing "XII" special character

Download all attachments as: .zip

Change History (9)

Changed 18 months ago by darksoul42

Attachment: SQ4 PC98 SJIS bugs.txt added

List of SJIS font errors given by ScummVM and of how/when to trigger them

comment:1 Changed 18 months ago by darksoul42

I just tried the latest version of ScummVM available (1.9 instead of 1.7), and it turns out the font issues were fixed. (Did not verify for all of them, but for a hefty sample of them, they were)

Changed 18 months ago by darksoul42

Missing "XII" special character

comment:2 Changed 18 months ago by darksoul42

After looking at all the instances of buggy fonts I had recorded, I can confirm they were actually all fixed.

The only remaining instance of font glitches would be in the first messages you see in the game after the opening, where the font set seemingly lacks a special character for XII. (The line where the narrator mentions casually glancing at the status bar)

comment:3 Changed 18 months ago by m-kiewitz

Which ScummVM version did you use originally?

Thanks for trying this out. I own basically all Sierra SCI Japanese games, but never had the time to play through them. Do you own more of them?
I got most of mine from yahoo auctions.

comment:4 Changed 18 months ago by m-kiewitz

Hmm, I don't know where you got the SJIS.FNT from, but the one that I created myself works fine. The XII characters are also working.

I think we only deliver a creation tool because of rights issues and you need sazanami-mincho.ttf (size 10.573.340 Bytes). Put those two together and you get a proper SJIS.FNT. Mine is 497.890 bytes.

I will leave this on pending for now. It seems it already works fine.
I think I fixed those Space Quest 4 issues some years ago and maybe there even was a problem with the font creation itself, I'm not sure. Pretty sure that I talked with LordHoto about that back then.

comment:5 Changed 18 months ago by m-kiewitz

Owner: set to m-kiewitz
Resolution: worksforme
Status: newpending

comment:6 Changed 15 months ago by csnover

Status: pendingclosed

Closing due to no response to the request for additional information. If this is still a problem, please provide the additional information, and this ticket can be reopened.

comment:7 Changed 14 months ago by darksoul42

Sorry for the delay in answering.

I had been using ScummVM as provided in Ubuntu, so version 1.7. (I am currently playing around with 1.9 and 2.0, on the same environment)

I also now own most if not all (I think this would be : QFG1, PQ2, KQ5, SQ4, Castle of Doctor Brain) of the japanese SCI titles and would be willing to test.

As for my SJIS.FNT, it was made out of a Windows environment 2 years ago with a procedure (most likely the one you mention, though I can't be 100% sure), and it is the same size as yours, 497890 bytes (though that is not much of a surprise. MD5 hash is 9e63050ff6a918f64c576f287ec41e27)

I guess I'll try remaking the font again and see if it changes things. Though to be honest, this is very minor.

Note: See TracTickets for help on using tickets.