Opened 2 years ago

Closed 2 years ago

#10225 closed enhancement (wontfix)

SCI: Lighthouse: Make crossing bridge to sub easier

Reported by: dafioram Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Lighthouse

Description

Game: Lighthouse 1.0c/2.0a
Tester OS: Win7-64
ScummVM: 1.10.0git-4977-g5c6de7d

In ScummVM and the original game when crossing the bridge to the submarine on Martin's Roost (the tower). if you don't click when the forward arrow is shown, but when the pointer is shown bridge will recede and you will have to solve that puzzle again.

This makes sense, but the problem is you would expect clicking anywhere along the bridge would have you move forward, but the game only has the forward arrow for a small area above the bridge. Clicking everywhere else (except turning around) resets the bridge.

I would like a greater click area to move the player forward rather than reset the bridge.

Attachments (3)

lighthouse-1.016 (124.9 KB ) - added by dafioram 2 years ago.
in front of sub bridge
scummvm00004.png (152.8 KB ) - added by dafioram 2 years ago.
Moving the mouse into this red area shows a forward arrow and click there would move you across the bridge. This area is too small.
scummvm00005.png (148.5 KB ) - added by dafioram 2 years ago.
I would prefer the click area in which would move you forward would be something larger like this.

Download all attachments as: .zip

Change History (6)

by dafioram, 2 years ago

Attachment: lighthouse-1.016 added

in front of sub bridge

by dafioram, 2 years ago

Attachment: scummvm00004.png added

Moving the mouse into this red area shows a forward arrow and click there would move you across the bridge. This area is too small.

by dafioram, 2 years ago

Attachment: scummvm00005.png added

I would prefer the click area in which would move you forward would be something larger like this.

comment:1 by dafioram, 2 years ago

The data files that I thought were for 1.0c are, I believe actually 2.0, so you can ignore this bug being for 1.0c since I cannot test that.

comment:2 by csnover, 2 years ago

Keywords: sci32 added

comment:3 by csnover, 2 years ago

Owner: set to csnover
Resolution: wontfix
Status: newclosed

Thanks for your report! While this may not be an ideal hit box size, there is no apparent error in the game programming, so this would be outside of the scope of the sorts of game enhancements made in ScummVM.

Note: See TracTickets for help on using tickets.