Opened 7 years ago

Closed 21 months ago

#10224 closed defect (fixed)

SCI: Lighthouse: Hitting Roost bird with rock has bad sound

Reported by: dafioram Owned by: sluicebox
Priority: normal Component: Engine: SCI
Version: Keywords: sci32 original
Cc: Game: Lighthouse

Description

Game: Lighthouse 1.0c/2.0a
Tester OS: Win7-64
ScummVM: 1.10.0git-4977-g5c6de7d

I used the same saved game from 2.0a to test lighthouse 1.0c in ScummVM.

This is not present in the original game v2.0a, but I don't know about 1.0c. I am playing the original game using Jafa's winxp installation. ​http://www.squirtthecat.com/games/lighthouse/index.html. Which is one of the two options endorsed by ​http://www.sierrahelp.com/Games/LighthouseHelp.html

When you throw a rock at the mechanical bird on the middle level of Martin's Roost the sound of the rock hitting the bird will sound like a buzz sound rather than a single metal clink sound.

Attachments (1)

lighthouse-1.013 (113.1 KB ) - added by dafioram 7 years ago.
top or roost (2.0a)

Download all attachments as: .zip

Change History (8)

by dafioram, 7 years ago

Attachment: lighthouse-1.013 added

top or roost (2.0a)

comment:1 by dafioram, 7 years ago

The data files that I thought were for 1.0c are, I believe actually 2.0, so you can ignore this bug being for 1.0c since I cannot test that.

comment:2 by dafioram, 7 years ago

Here is my play through of this on the original engine. https://streamable.com/6vg2d

comment:3 by dafioram, 7 years ago

This sound effect in scummvm is reproducible when playing lighthouse 2.0a on dosbox. https://streamable.com/l4fgi

comment:4 by csnover, 7 years ago

Keywords: sci32 added

comment:5 by bluegr, 6 years ago

This happens in room 470. It's a script bug, as the game tries to play the same sound sample 5 times

comment:6 by bluegr, 2 years ago

Here's a video, fast forwarded to this scene:
https://www.youtube.com/watch?v=PrmNgq9EUtY#t=17m7s

comment:7 by sluicebox, 21 months ago

Keywords: original added
Owner: set to sluicebox
Priority: lownormal
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.