Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#10200 closed defect (fixed)

SCI: Shivers1: Sound Crash in Gods and Godessess Room

Reported by: dafioram Owned by: dafioram
Priority: high Component: Engine: SCI
Keywords: sci32 Cc:
Game: Shivers 1

Description

ScummVM:1.10.0git-4845-ge1c33a6
Game: Shivers1 GOG
OS: Ubuntu-64 16.04

When in the funeral rites room if you spin around it will crash. It appears to be random. It also happens if I just regularly click so maybe the sound is changing at the same time I click.

I was able to get this error in rooms: 23060, 23050, 23120, and 23230 for sound1::check() and sound2::check()

lookupSelector: Attempt to send to non-object or invalid script. Address 0000:0010, method sound1::check (room 23230, script 64989, localCall ffffffff)!
0: script 0 - SHIVERS::replay() obj@0001:215d pc=0001:0c02 sp=ST:0007 fp=ST:0000 argp:ST:0001
1: script 0 - SHIVERS::doit()  by 0 obj@0001:215d pc=0001:10e6 sp=ST:0009 fp=ST:0009 argp:ST:0008
2: script 64994 - Game::doit() by 1 obj@0001:215d pc=0005:06c2 sp=ST:000e fp=ST:000b argp:ST:000a
3: script 64999 - SoundManager::eachElementDo(0000:00f8) by 2 obj@0003:09f0 pc=0006:048d sp=ST:0013 fp=ST:0011 argp:ST:000f
4:[3]  kListEachElementDo(0016:0015, 0000:00f8) by 3 obj@0000:0000 pc:none argp:ST:0014
5: script 64989 - sound1::check() by 4 obj@0001:1fc7 pc=000a:0266 sp=ST:001c fp=ST:0019 argp:ST:0018

Attachments (2)

shivers-win.017 (26.1 KB) - added by dafioram 19 months ago.
funeral rites room
btrace.txt (548.2 KB) - added by dafioram 19 months ago.
sound2 crashes

Download all attachments as: .zip

Change History (7)

Changed 19 months ago by dafioram

Attachment: shivers-win.017 added

funeral rites room

comment:1 Changed 19 months ago by dafioram

Summary: SCI: Shivers1: Sound Crash in Funeral Rites RoomSCI: Shivers1: Sound Crash in Gods and Godessess Room

comment:2 Changed 19 months ago by csnover

Keywords: sci32 added

Changed 19 months ago by dafioram

Attachment: btrace.txt added

sound2 crashes

comment:3 Changed 19 months ago by csnover

Owner: set to dafioram

Per IRC, this is caused by an incorrect play call which is supposed to be a fade call in room 23090. dafioram is working on writing a script patch for this, with my assistance.

comment:4 Changed 19 months ago by csnover

Owner: dafioram deleted
Resolution: fixed
Status: newclosed

Thanks for your help! Your patch for this issue has been landed in commit 817c9e77aa6f2c40571e807888bace46b08d0142 and will be available in daily builds 1.10.0git-4885 and higher.

comment:5 Changed 19 months ago by csnover

Owner: set to dafioram
Note: See TracTickets for help on using tickets.