Opened 2 years ago

Closed 2 years ago

#10181 closed defect (duplicate)

SCI: LSL7: Unable to save

Reported by: DanielSWolf Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Leisure Suit Larry 7

Description

During gameplay, if I press Ctrl+F5 to open ScummVM's options menu, there's a "Load" button but no "Save" button. So I'm unable to save the game. Other games (I tried Monkey Island 1) work fine.

See the attached screenshot.

I'm playing the English version on Windows 7 using the latest nightly build, 1.10.0git4748-g128edee

Attachments (1)

options.png (260.2 KB ) - added by DanielSWolf 2 years ago.

Download all attachments as: .zip

Change History (4)

by DanielSWolf, 2 years ago

Attachment: options.png added

comment:1 by DanielSWolf, 2 years ago

Note that if I check "Use original save/load screens" in the ScummVM launcher, everything works fine. The original menu will let me save and restore without problems.

comment:2 by g5ppc, 2 years ago

This is probably working as designed. On some of these newer SCI games, ScummVM doesn't make save available as it doesn't know when it should be allowed. You have to use the in-game menubar (which unfortunately auto-hides) or press Ctrl-S or whatever keyboard shortcut Sierra used.

A UI hint might be a good enhancement.

comment:3 by csnover, 2 years ago

Component: --Unset--Engine: SCI
Keywords: sci32 added
Owner: set to csnover
Resolution: duplicate
Status: newclosed

Thanks for your report! This is not a bug; it is not currently possible to save from the launcher due to limitations in determining whether the engine is in a savable state, so the save button is not shown in the launcher. There is an open enhancement request regarding this issue; please see #9781 for more information.

Note: See TracTickets for help on using tickets.