#10169 closed defect (fixed)

TITANIC: PET display for star puzzle can persistence out of star puzzle

Reported by: dafioram Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

1.10.0git-4664-g1def441

  1. Load saved game at bridge before starting puzzle
  2. Put on helmet (don't need to put in picture)
  3. Click Set Destination
  4. Take off helmet
  5. Immediately put helmet back on
  6. Wait, the screen should visibly refresh
  7. Take off the helmet

Now the PET that says Set Destination will be shown at the bottom even though you are not doing the puzzle. I previously observed this when I finished the puzzle and this bug was happening.

There may be other ways to reproduce this that involve clicking the Set Destination, button. Whenever that screen refresh happens that is the indication that this bug is set.

Present in the original engine!

Attachments (2)

scummvm00000.png (129.8 KB) - added by dafioram 20 months ago.
712A.gam (87.2 KB) - added by dafioram 20 months ago.
bridge

Download all attachments as: .zip

Change History (6)

Changed 20 months ago by dafioram

Attachment: scummvm00000.png added

Changed 20 months ago by dafioram

Attachment: 712A.gam added

bridge

comment:1 Changed 20 months ago by dreammaster

Owner: set to dreammaster
Resolution: worksforme
Status: newpending

I just tried this tonight and couldn't replicate it. Has one of your refactorings perhaps fixed it?

comment:2 Changed 20 months ago by dafioram

None of my changes should of fixed that. It has something to do with timing.

  1. Try hitting the set destination button without locking anything and then
  2. go out of the puzzle and back in and wait a bit maybe 8 secs
  3. repeat 2, 2 or 3 times, if you see the screen visibable refresh then bug is set.

If it didn't happen after going in and out 2-3 then you will have to load a saved game and try again.

It should also happen if u have finished the puzzle normally, but that will take more time for testing.

Want me to make a video recording of this?

comment:3 Changed 20 months ago by dafioram

I reproduced it in aceff5852e7f769773f5932c46201ab2c3299a9c (Sep 7):
Demo without solving puzzle
Demo with solving puzzle

comment:4 Changed 20 months ago by dreammaster

Resolution: worksformefixed
Status: pendingclosed

Thanks for that.. with the video, and some extra debugging, I realised the problem was happening when you turned the NAV halmet back on before the animation from leaving the star view was fully complete. It wasn't getting the chance to unlock the PET, so when the starview was left a second time, it remained locked, and couldn't switch back to the remote view.

Note: See TracTickets for help on using tickets.