#10166 closed defect (invalid)

SCI: PHANT2: GOG.com release missing voice when guessing password

Reported by: domino1983 Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 gog-bug Cc:
Game: Phantasmagoria 2

Description

When you are entering the password to view your document, you should be able hear a voice. Instead I get a message:
WARNING: [Audio32::play]: audio36.6301(16, 0, 60, 1) could not be found!

I'm playing GOG english version. Win7 x64 latest daily build.

Attachments (3)

phantasmagoria2-cd-win.006 (55.8 KB) - added by domino1983 20 months ago.
directory-listing.txt (49.4 KB) - added by domino1983 20 months ago.
phantasmagoria2-cd-win.009 (55.0 KB) - added by domino1983 20 months ago.

Download all attachments as: .zip

Change History (12)

Changed 20 months ago by domino1983

Attachment: phantasmagoria2-cd-win.006 added

comment:1 Changed 20 months ago by csnover

I am not able to reproduce this issue with the US English CD release, so this looks to be some problem specific to the GOG release. Could you please run dir /s path\to\phant2\directory > directory-listing.txt and then attach the directory-listing.txt file that is created to this ticket? Thanks!

Changed 20 months ago by domino1983

Attachment: directory-listing.txt added

comment:2 Changed 20 months ago by domino1983

Here you go.

comment:3 Changed 20 months ago by csnover

Keywords: sci32 added

comment:4 Changed 20 months ago by csnover

Owner: set to csnover
Resolution: invalid
Status: newclosed

Thanks for your report! Unfortunately, after some investigation, it appears that the GOG release of this game is missing data for this audio cue. This is not a ScummVM bug, but rather a problem with the data from GOG. You may want to contact them so that they can fix their data files. They are missing, at least, the 6301.MAP resource. In the original 1996 US CD release, this resource was present in every RESSCI.00x file on every CD.

comment:5 Changed 20 months ago by csnover

Resolution: invalid
Status: closednew

I am receiving conflicting information regarding this ticket. Please stand by for further detail…

comment:6 Changed 20 months ago by csnover

Summary: SCI: Phantasmagoria 2 can't hear any voice when guessing passwordSCI: PHANT2: Missing voice when guessing password

So, OK. It sounds like map 6301 does actually exist in RESSCI.000, but it has no data in it, which means the end result is the same. Since there was some initial confusion about this, I am going to hold this ticket open a bit longer until I’m totally confident that we are not doing something broken when parsing the resource map (this is unlikely, but not impossible).

comment:7 Changed 20 months ago by domino1983

I've tested this problem with original interpreter and I can confirm there's no voice in DOSBox too. So I guess GOG somehow messed their data since I also get no voice when trying to go to no available places like Doc or Borderline on the map. I get a message:
WARNING: [Audio32::play]: audio36.900(1, 0, 3, 1) could not be found!
I've attached my savegame so you can test this.

Changed 20 months ago by domino1983

Attachment: phantasmagoria2-cd-win.009 added

comment:8 Changed 20 months ago by csnover

Keywords: gog-bug added
Summary: SCI: PHANT2: Missing voice when guessing passwordSCI: PHANT2: GOG.com release missing voice when guessing password

comment:9 Changed 20 months ago by csnover

Resolution: invalid
Status: newclosed

The necessary data for resolving this problem have been successfully passed on to GOG.com’s product team. At this point it is up to them to publish an updated copy of the game containing the missing data.

Note: See TracTickets for help on using tickets.