Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1016 closed defect (fixed)

MI1: palette effect missing

Reported by: SF/logicdeluxe Owned by: SF/jamieson630
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

ScummVM 0.5.0pre-cvs
Built on Jul 13 2003 02:36:02
With the vga disk version, there is no pallette effect
in the caves under Monky Island. This works fine with
the enhanced CD version. There even is no warning in
the debug output concerning the pallette effect.

Ticket imported from: #770687. Ticket imported from: bugs/1016.

Attachments (1)

monkeyvga.s10 (60.2 KB) - added by SF/logicdeluxe 16 years ago.

Download all attachments as: .zip

Change History (10)

Changed 16 years ago by SF/logicdeluxe

Attachment: monkeyvga.s10 added

comment:1 Changed 16 years ago by fingolfin

Summary: MI1: pallette effect missingMI1: palette effect missing

comment:2 Changed 16 years ago by fingolfin

So, have you verified that effect is there with the original engine?

comment:3 Changed 16 years ago by SF/logicdeluxe

Yes, it is shown with the original interpreter. Looks the
same as in the enhanced CD version.

comment:4 Changed 16 years ago by SF/logicdeluxe

This also happens to Hook's sign on Melee. The light bulbs
are supposed to flash.

comment:5 Changed 16 years ago by Kirben

The problem is caused by ScummVM not updating the screen
with the palette changes from _shadowPalette in case 4 of
o5_roomOps.

comment:6 Changed 16 years ago by Kirben

Nevermind my last comment, we found out through
ScummRev that monkeyvga has a different color cycle
resource with a 'CC' header and a different format.

comment:7 Changed 16 years ago by Kirben

According to ScummRev loomcd has the same CC style
resources for color cycling

Do you know if original monkeyega had the same palette
effect ? I can't see any color cycling resources in its data
files.

comment:8 Changed 16 years ago by Kirben

Color Cycling for monkeyvga has been added to ScummVM
cvs, thanks to jamieson. The palette effects at the two
locations mentioned now work correctly.

comment:9 Changed 16 years ago by Kirben

Owner: set to SF/jamieson630
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.