Opened 2 years ago

Closed 2 years ago

#10151 closed defect (fixed)

TITANIC: Succubus in parrot room hose + chicken (spoilers)

Reported by: dafioram Owned by: dreammaster
Priority: low Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

If you send the chicken to the parrot room and you first hook up the hose to him then disconnect him then turn him back on he says he has something for you, but if you hit receive a bunch of times you get nothing. You have to first turn away and then turn back and you can receive the chicken.

If you send the specially prepared chicken to the succubus in the parrot room he says something different then when returning different items so this maybe why theirs an issue with getting the item immediately when the hose is used first.

I did a test by sending another item besides the chicken and doing the hose connection first and the succubus gave that item back just fine.

Don't know if it is in the original or not.

Attachments (1)

titanic-win.062 (103.3 KB ) - added by dafioram 2 years ago.
parrot room, have hose, chicken is in succ queue

Download all attachments as: .zip

Change History (5)

by dafioram, 2 years ago

Attachment: titanic-win.062 added

parrot room, have hose, chicken is in succ queue

comment:1 by dreammaster, 2 years ago

I must have tried to replicate this problem about a dozen times, and was only able to get the problem to happen once. It seems the CPetonControl _remoteTarget is getting set to nil - this is the variable that initially contains the SuccUBus. It's likely an incorrect call at some point to resetRemoteTarget or setRemoteTarget with a nullptr parameter. Unfortunately, after realising that _remoteTarget was null, I haven't since been able to replicate the problem again.

It may be due to some specific action you're taking such as switching PET tabs, whether you do any extra clicks on the SuccUBus glyph in the PET remote tab, etc.

comment:2 by dreammaster, 2 years ago

Owner: set to dreammaster
Resolution: worksforme
Status: newpending

comment:3 by dafioram, 2 years ago

  1. Load saved game. This has the chicken in the scuccubus queue and I have already gotten the nose.
  2. Connect the hose to succubus
  3. Disconnect hose from succubus
  4. Turn on succubus, he says that thing you sent is here
  5. Click receive. Nothing happens. Doesn't matter how many times you click receive nor how many times you turn him on and off. You also can't send anything from him in this state. It is required that you look away and back before he works properly (and give you the chicken you sent).

If you do these steps before getting the nose it works as intended.

comment:4 by dreammaster, 2 years ago

Resolution: worksformefixed
Status: pendingclosed

Fixed. The problem was a '_remoteTargetName' field on the PET wasn't set in the savegame; it specifies which game object the Send/Receive buttons call. When first loading the game from the launcher it didn't matter, because the engine startup calls the view entry code for the Parrot Succubus which sets it, but when I loaded the same savegame a second time from within the game, the view entry code isn't called (which is correct), so the fact that the remote target name was blank in the savegame meant that it wasn't set, and the send/receive buttons did nothing.

If you wanted to fix your savegame, you'd need to simply turn away from the SuccUBus, then turn back and resave the game, since the fix ensures that the correct target name will be saved. Thereafter, the buttons will work after loading the savegame.

Note: See TracTickets for help on using tickets.