Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#10150 closed defect (fixed)

TITANIC: Can open GMM onto of F5/F7 save/load

Reported by: dafioram Owned by: bgK
Priority: low Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

Looks weird since you can open another load menu on top of the previous menu.

Attachments (1)

scummvm00001.png (38.0 KB) - added by dafioram 20 months ago.

Download all attachments as: .zip

Change History (4)

Changed 20 months ago by dafioram

Attachment: scummvm00001.png added

comment:1 Changed 20 months ago by dafioram

Summary: TITANIC: Cam open GMM onto of F5/F7 save/loadTITANIC: Can open GMM onto of F5/F7 save/load

comment:2 Changed 20 months ago by dreammaster

Owner: set to dreammaster
Resolution: wontfix
Status: newclosed

It may look weird, but that's ScummVM working as intended. Nothing in-game can block the GMM from appearing (so long as the game allows event processing to happen). Even though I'm re-using the code for the save & load dialogs, it still counts as in-game. I'm therefore going to close this as a wontfix.

comment:3 Changed 20 months ago by bgK

Owner: changed from dreammaster to bgK
Resolution: wontfixfixed

Engines are expected to be paused while showing ScummVM dialogs (Like in Engine::runDialog). The GMM is blocked when an engine is already paused.

Fixed in 42c6f68f7a.

Note: See TracTickets for help on using tickets.