Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#10130 closed defect (worksforme)

TITANIC: Prod'ing the MaitreD takes too long

Reported by: dafioram Owned by: dreammaster
Priority: normal Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

1.10.0git-4488-ga8e400e

Original: 51 secs
ScummVM: 124 secs

Did one trial each.

Change History (2)

comment:1 Changed 20 months ago by dreammaster

Owner: set to dreammaster
Resolution: worksforme
Status: newclosed

Actually, I think this is working as intended.. it's just all too easy to accidentally click on the MaitreD's legs, rather than the buttocks, which doesn't count towards the "prod buttocks count". When I went to the CMaitreDProdReceptor::ProdMaitreDMsg method and hardcoded the (now renamed) _prodSource to MAITRED_BUTTOCKS, I was able to get him to surrender in approximately 40 seconds.

comment:2 Changed 20 months ago by dafioram

After trying it again I was able to get him to surrender in about a minute. Thats okay. I think I was probably clicking on the legs a lot more last time as you mentioned.

Note: See TracTickets for help on using tickets.